4 Replies Latest reply on Jan 3, 2008 6:58 PM by David Baker

    JBoss with JDK1.5

    Thanh Do Newbie

      ===============================================================================
      .
      JBoss Bootstrap Environment
      .
      JBOSS_HOME: D:\jboss-4.0.4.GA.patch1\bin\\..
      .
      JAVA: D:\Java\j2sdk1.5.0\jre\bin\java
      .
      JAVA_OPTS: -Dprogram.name=run.bat -Xms128m -Xmx512m -Dsun.rmi.dgc.client.gcIn
      terval=3600000 -Dsun.rmi.dgc.server.gcInterval=3600000
      .
      CLASSPATH: D:\Java\j2sdk1.5.0\jre\lib\tools.jar;D:\jboss-4.0.4.GA.patch1\bin\\
      run.jar
      .
      ===============================================================================
      .
      08:51:40,750 INFO [Server] Starting JBoss (MX MicroKernel)...
      08:51:40,765 INFO [Server] Release ID: JBoss [Zion] 4.0.4.GA (build: CVSTag=JBo
      ss_4_0_4_GA date=200605151000)
      08:51:40,765 INFO [Server] Home Dir: D:\jboss-4.0.4.GA.patch1
      08:51:40,781 INFO [Server] Home URL: file:/D:/jboss-4.0.4.GA.patch1/
      08:51:40,781 INFO [Server] Patch URL: null
      08:51:40,781 INFO [Server] Server Name: default
      08:51:40,781 INFO [Server] Server Home Dir: D:\jboss-4.0.4.GA.patch1\server\def
      ault
      08:51:40,781 INFO [Server] Server Home URL: file:/D:/jboss-4.0.4.GA.patch1/serv
      er/default/
      08:51:40,796 INFO [Server] Server Log Dir: D:\jboss-4.0.4.GA.patch1\server\defa
      ult\log
      08:51:40,796 INFO [Server] Server Temp Dir: D:\jboss-4.0.4.GA.patch1\server\def
      ault\tmp
      08:51:40,796 INFO [Server] Root Deployment Filename: jboss-service.xml
      08:51:40,968 WARN [BasicMBeanRegistry] javax.management.MBeanRegistrationExcept
      ion: preRegister() failed: [ObjectName='JMImplementation:type=MBeanServerDelegat
      e', Class=javax.management.MBeanServerDelegate (javax.management.MBeanServerDele
      gate@2a4983)]
      Failed to boot JBoss:
      java.lang.RuntimeException: Cannot create MBeanServer
      at org.jboss.mx.server.MBeanServerImpl.(MBeanServerImpl.java:239)
      at org.jboss.mx.server.MBeanServerBuilderImpl.newMBeanServer(MBeanServer
      BuilderImpl.java:71)
      at javax.management.MBeanServerFactory.newMBeanServer(MBeanServerFactory
      .java:316)
      at javax.management.MBeanServerFactory.createMBeanServer(MBeanServerFact
      ory.java:219)
      at org.jboss.system.server.ServerImpl.doStart(ServerImpl.java:420)
      at org.jboss.system.server.ServerImpl.start(ServerImpl.java:362)
      at org.jboss.Main.boot(Main.java:200)
      at org.jboss.Main$1.run(Main.java:464)
      at java.lang.Thread.run(Thread.java:566)
      Caused by: javax.management.MBeanRegistrationException: preRegister() failed: [O
      bjectName='JMImplementation:type=MBeanServerDelegate', Class=javax.management.MB
      eanServerDelegate (javax.management.MBeanServerDelegate@2a4983)]
      at org.jboss.mx.server.registry.BasicMBeanRegistry.invokePreRegister(Bas
      icMBeanRegistry.java:713)
      at org.jboss.mx.server.registry.BasicMBeanRegistry.registerMBean(BasicMB
      eanRegistry.java:211)
      at org.jboss.mx.server.MBeanServerImpl.(MBeanServerImpl.java:215)
      ... 8 more
      Caused by: javax.management.RuntimeOperationsException: Exception occured trying
      find the descriptors of the MBean
      at javax.management.modelmbean.ModelMBeanInfoSupport.getDescriptors(Mode
      lMBeanInfoSupport.java:445)
      at org.jboss.mx.modelmbean.ModelMBeanInvoker.initPersistence(ModelMBeanI
      nvoker.java:538)
      at org.jboss.mx.modelmbean.ModelMBeanInvoker.init(ModelMBeanInvoker.java
      :520)
      at org.jboss.mx.modelmbean.ModelMBeanInvoker.invokePreRegister(ModelMBea
      nInvoker.java:486)
      at org.jboss.mx.server.AbstractMBeanInvoker.preRegister(AbstractMBeanInv
      oker.java:654)
      at org.jboss.mx.server.registry.BasicMBeanRegistry.invokePreRegister(Bas
      icMBeanRegistry.java:697)
      ... 10 more
      Caused by: java.lang.IllegalArgumentException: Descriptor Type is invalid
      ... 16 more
      Press any key to continue . . .

      -----------------------------------------------------------------------
      Hi everybody,
      Could you tell me how I can run Jboss with JDK1.5
      Thanks for advance

        • 1. Re: JBoss with JDK1.5
          Peter Johnson Master

          I suspect a faulty installation. Could you download and install again?

          • 2. Re: JBoss with JDK1.5
            Thanh Do Newbie

            Thanks for reply.
            I install and run with
            jboss-3.2.8.SP1.zip
            jboss-4.0.4.CR3-installer.jar
            jboss-4.0.4.GA-Patch1-installer.jar
            and I also install in some computer
            It has the same error.
            Best regards

            • 3. Re: JBoss with JDK1.5
              Peter Johnson Master

              Which patch release of the JVM are you running? Is it the original 1.5? I am running patch release 6 (1.5.0_06). I googled thep roblem and it seems that others have had problems with running JBoss on earlier versions of 1.5. I have run 3.2.7, 4.0.2, 4.0.3SP1 and 4.0.4 on JVM 1.5.0_06 without problems.

              Also, set JAVA_HOME to the JDK, not to the JRE.

              • 4. Re: JBoss with JDK1.5
                David Baker Newbie

                I ran into the same problem and once I made sure the hostname was correct in both the HOSTNAME and network files, it worked fine. The error is being generated by a preRegister() function which calls a domain name validation check. So...either you need to have the hostname on a DNS server or the fully qualified host name has to be in your /etc/hosts file. This appears to be similar to the Apache Servername check done you start up Apache httpd, at least....that was the fix for me.

                Dave Baker
                Just another JBoss user