0 Replies Latest reply on Aug 6, 2006 3:57 PM by Mike Holloway

    JBOSS install probs, on server w/o X11

    Mike Holloway Newbie

      Hello everyone... I have been beating my head against this for a while now and am looking for some help. I am trying to create an application server for home development projects. I am pretty new to linux, and JBOSS.

      I have installed Ubuntu Server 6.06 (LAMP Server), Java 1.5, and am now trying to install JBOSS Application server. The problem is that it requires a GUI for installation. I am now trying to fight through the X11 forwarding issues to get this installed. I think I am getting closer. X11 fowarding is enabled in my sshd_config. Here is what I have added to my profile:

      export JAVA_HOME="/usr/lib/jdk"
      export PATH=$JAVA_HOME/bin:$PATH
      export DISPLAY=192.168.0.3:0 (this is my windows box)

      and here is my current error:
      mike@homer:~$ java -jar jboss-4.0.4.GA-Patch1-installer.jar
      Exception in thread "main" java.lang.UnsatisfiedLinkError: /usr/lib/jdk1.5.0_07/jre/lib/i386/xawt/libmawt.so: libXext.so.6: cannot open shared object file: No such file or directory
      at java.lang.ClassLoader$NativeLibrary.load(Native Method)
      at java.lang.ClassLoader.loadLibrary0(ClassLoader.jav a:1751)
      at java.lang.ClassLoader.loadLibrary(ClassLoader.java :1647)
      at java.lang.Runtime.load0(Runtime.java:769)
      at java.lang.System.load(System.java:967)
      ...........

      This file does not exist: libXext.so

      and now I am starting to wonder if I have been going down the wrong path... I am using putty to connect from an XP machine. Here is part of the log file on login:
      2006-08-06 10:10:01 Access granted
      2006-08-06 10:10:01 Opened channel for session
      2006-08-06 10:10:01 Requesting X11 forwarding
      2006-08-06 10:10:01 Remote debug message: No xauth program; cannot forward with spoofing.
      2006-08-06 10:10:01 X11 forwarding refused
      2006-08-06 10:10:01 Allocated pty (ospeed 38400bps, ispeed 38400bps)
      2006-08-06 10:10:02 Started a shell/command
      I have X11 forwarding enabled and have tried both of the protocols.. Any ideas on where I can get the above SO, or what packages I need to install for Ubuntu?

      If anyone can give me some advice I would greatly appreciate it...

      Thanks, Mike
      Reply With Quote