1 Reply Latest reply on Aug 18, 2006 10:39 AM by Peter Johnson

    dom4j.jar shipped with Jboss 4.0.4.GA causing problems

    Fredrik Hellström Newbie

      Hi all,

      I'm developing an application that uses a 3rd party reporting engine (Windward). The reporting engine requires the latest version of dom4j.jar (currently version 1.6.1).

      Since Jboss provides its own (rather old?) version of dom4j.jar this version will be loaded by the "global" class loader and this cause problems.

      To solve this problem I have replaced the dom4j.jar provided with jboss with a never version.

      My questions:
      - Will future releases of jboss be shipped with an upgraded version of dom4j?
      - Is there any way I can avoid patching the jboss installation? (Maybe there is a nice config file I can use to influence the class loader...?)
      - Are there any important dependencies between jboss GA and the dom4j version it contains that I should know of?

      Regards,
      Fredrik