0 Replies Latest reply on Sep 19, 2006 3:18 AM by madan srinivas

    EJB3.0 compliant JBoss Server version

    madan srinivas Newbie

      Pls let me know if JBoss 4.0.4 CR2 supports EJB3.0.

      I have updated JBoss4.0.1sp1 to JBoss4.0.4 CR2 using patch EJB 3.0 RC6.

      but still i get following errors while deploying my EJB3.0 jars


      Bean : FileDetailsServiceBO
      Section: 10.6.2
      Warning: The entity bean's class must implement, directly or indirectly, the jav
      ax.ejb.EntityBean interface.

      12:11:59,663 WARN [verifier] EJB spec violation:
      Bean : FileDetailsServiceBO
      Section: 10.6.2
      Warning: The entity bean class must be defined as public and abstract.

      12:11:59,663 WARN [verifier] EJB spec violation:
      Bean : FileDetailsServiceBO
      Section: 10.6.1
      Warning: The Bean Provider must provide a remote interface and a remote home int
      erface or a local interface and a local home interface for the bean.

      12:11:59,663 ERROR [MainDeployer] could not create deployment: file:/D:/Program
      Files/JBoss/jboss-4.0.1sp1/server/default/deploy/FileDetails.jar
      org.jboss.deployment.DeploymentException: Verification of Enterprise Beans faile
      d, see above for error messages.