7 Replies Latest reply on Oct 12, 2006 7:12 PM by brooks j

    Could not open Jboss Welcome page!!!

    brooks j Newbie

      OS:Linux
      JDK:JDK 1.5
      I had installed JBoss 4.0.4.GA on linux and startup success(i can see jBoss startup output ).But I can not open Jboss welcome page from another comupter(windows xp),I type "http://192.168.2.19:8080/" on my windows brower.it doesn't work.I can ping linux(192.168.2.19) success.btw ,my linux's network is DHCP.what can i do?

        • 1. Re: Could not open Jboss Welcome page!!!
          Peter Johnson Master

          Do you have iptables (or some other firewall) running on the linux system? If so, is port 8080 open? Does the Linus system have a monitor, and if so, can you access JBoss from there using http://localhost:8080?

          • 2. Re: Could not open Jboss Welcome page!!!
            brooks j Newbie

             

            "PeterJ" wrote:
            Do you have iptables (or some other firewall) running on the linux system? If so, is port 8080 open? Does the Linus system have a monitor, and if so, can you access JBoss from there using http://localhost:8080?

            hi,guy,
            thank you for replying,I'm not sure whether some firewall running on my linux.But I use nmap ,netstat,find the port 8080 is open.So what's wrong with my linux.Btw,my linux is running on the command line,so I don't know how to access "http://localhost:8080" on the command line.

            nmap -A -sT localhost

            Starting Nmap 4.11 ( http://www.insecure.org/nmap/ ) at 2006-06-19 01:51 EDT
            Interesting ports on yyy (127.0.0.1):
            Not shown: 1671 closed ports
            PORT STATE SERVICE VERSION
            22/tcp open ssh OpenSSH 4.3 (protocol 2.0)
            25/tcp open smtp Sendmail 8.13.5/8.13.5
            111/tcp open rpcbind 2 (rpc #100000)
            631/tcp open ipp CUPS 1.1
            4444/tcp open krb524?
            8009/tcp open ajp13?
            8080/tcp open http Apache Tomcat/Coyote JSP engine 1.1
            50000/tcp open hpiod HP Linux Imaging and Printing System
            50002/tcp open iiimsf?
            Device type: general purpose
            Running: Linux 2.4.X|2.5.X|2.6.X
            OS details: Linux 2.4.0 - 2.5.20, Linux 2.5.25 - 2.6.8 or Gentoo 1.2 Linux 2.4.19 rc1-rc7, Linux 2.6.3 - 2.6.10
            Service Info: Host: localhost.localdomain; OS: Unix

            netstat -anp | grep 8080
            tcp 0 0 :::8080 :::* LISTEN 32529/java

            • 3. Re: Could not open Jboss Welcome page!!!
              Peter Johnson Master

              You can have port 8080 open and still have the firewall block access to the the port from extrnal machines. You really neeed to find out if a firewall is running. I don't use Gentoo (I run Fedore Core 5), so I am not sure the best way to find that out.

              Also, there are command-line HTTP clients that you can use to browse web sites. You only get text back, but it would be enough to show that JBoss is processing http requests. Perhaps you could try one of those. (I don't recall the name(s) of the http client, that was one of the installation options I turned off when I installed Fedora.)

              • 4. Re: Could not open Jboss Welcome page!!!
                brooks j Newbie

                 

                "PeterJ" wrote:
                You can have port 8080 open and still have the firewall block access to the the port from extrnal machines. You really neeed to find out if a firewall is running. I don't use Gentoo (I run Fedore Core 5), so I am not sure the best way to find that out.

                Also, there are command-line HTTP clients that you can use to browse web sites. You only get text back, but it would be enough to show that JBoss is processing http requests. Perhaps you could try one of those. (I don't recall the name(s) of the http client, that was one of the installation options I turned off when I installed Fedora.)


                hi,peterJ
                I run Fedore Core 5 too.I find firewall,it's iptables,now,what can I do?Turn firewall off?
                chkconfig --list|grep iptables
                iptables 0:off 1:off 2:on 3:on 4:on 5:on 6:off

                • 5. Re: Could not open Jboss Welcome page!!!
                  brooks j Newbie

                  ok,I can use command-line http client(Wget) access "http://localhost:8080".So,how to find port that firewall block and open it.

                  • 6. Re: Could not open Jboss Welcome page!!!
                    Peter Johnson Master

                    Here are the JBoss-related lines I added to /etc/sysconfig/iptables:

                    -A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 8080 -j ACCEPT
                    -A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 1099 -j ACCEPT
                    -A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 1098 -j ACCEPT
                    -A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 4444 -j ACCEPT
                    -A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 4445 -j ACCEPT


                    The above lines must go before these lines:

                    -A RH-Firewall-1-INPUT -j REJECT --reject-with icmp-host-prohibited
                    COMMIT



                    • 7. Re: Could not open Jboss Welcome page!!!
                      brooks j Newbie

                       

                      "PeterJ" wrote:
                      Here are the JBoss-related lines I added to /etc/sysconfig/iptables:

                      -A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 8080 -j ACCEPT
                      -A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 1099 -j ACCEPT
                      -A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 1098 -j ACCEPT
                      -A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 4444 -j ACCEPT
                      -A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 4445 -j ACCEPT


                      The above lines must go before these lines:

                      -A RH-Firewall-1-INPUT -j REJECT --reject-with icmp-host-prohibited
                      COMMIT


                      hi,PeterJ
                      Thank you so much,it's ok now!