2 Replies Latest reply on Oct 26, 2006 9:44 AM by Romeu Figueira

    Changed ports with partial success

    Romeu Figueira Newbie

      I'm deploying a JBoss AS 4.0.5 to a development enverionment on HP-UX. Due to some other application using port 8080 I had to change it to 8060.

      All of this worked out fine, I can access the web console throught the

      http://ip-address:8060


      Problem is that I'm using JBossWS and in that web console for endpoints
      http://ip-address:8060/jbossws/services


      my endpoints are still listed as runing on port 8080 (both on display and on using ?WSDL to show the code).

      Now, I've double checked my procedure by replicating in my test envirionment which is Windows and the same situation ocours. I've also looked into all xml files for descriptions of port 8080 and changed it to 8060, which worked, Jboss is on 8060.

      Now, how can I have my WS endpoints show up as 8060 instead of 8080?

      Regards,

      Romeu

        • 1. Re: Changed ports with partial success
          Andy Morris Newbie

          You've effectively changed the listener (i.e. the server side of the communication). You are referring to the ports that the webservice web application "thinks" the webservice is the listener on.

          Change the webserviceport in here:

          deploy/jbossws.sar/META-INF/jboss-service.xml

          Andy

          • 2. Re: Changed ports with partial success
            Romeu Figueira Newbie

            Thanks for the info.

            You've put me in the right path.

            So here goes my solution in case somebody else needs it.

            Running JBoss AS 4.0.5 with Jbossws.sar (JDK 1.5)

            What I did was to unzip the jbossws.beans file to a folder called jbossws.beans, then inside it changed the jboss-beans.xml file where the webserviceport was located (in Jbossws.sar (JDK 1.5), jboss-service.xml there was no webserviceport descriptor, nor could I add the similar one from JDK 1.4).

            It's running as it should now,

            thanks again andy.