1 Reply Latest reply on Nov 17, 2006 10:58 AM by infinity2heaven

    java.lang.IncompatibleClassChangeError in 4.0.5

    infinity2heaven Novice

      I get this error at runtime for my application deployed on JBoss 4.0.5 which has hibernate 3.

      java.lang.IncompatibleClassChangeError
      at org.hibernate.impl.SessionImpl.afterTransactionCompletion(SessionImpl.java:377)
      at org.hibernate.jdbc.JDBCContext.afterTransactionCompletion(JDBCContext.java:228)
      at org.hibernate.jdbc.JDBCContext.disconnect(JDBCContext.java:191)
      at org.hibernate.jdbc.JDBCContext.release(JDBCContext.java:88)
      at org.hibernate.impl.SessionImpl.close(SessionImpl.java:274)

      The same configuration deploys fine on JBoss 4.0.2.

      I tried googling and removed log4j jars (incompatible versions probably) from my application.war file but the problem still persisits

      what next?