2 Replies Latest reply on Dec 4, 2006 3:18 PM by Reza Poms

    Permission Issue

    Reza Poms Newbie

      Hello Forum

      I recently downloaded and installed jboss on a linux centos4.3 server @ /usr/local/jboss* Everything from jboss down is recursively chown'd by root:root EXCEPT the subfolder deploy @ servers/default/deploy where it's chown'd to our application. Our web application cannot run as root, so it's chown'd and it must create many files and folders within the linux file structure on the server in a grand parent folder. I've tried 3 things and all of them have failed:

      1. Everything at /usr/local/jboss was chown'd by root:root recursively as the installation default. The application launched successfully, jboss log recorded no errors but our application was unable to create children/grand children folders.

      2. Left everything as chown'd by root in jboss installation but in the deploy subfolder I left everything as root except chown'ing our application. Weird result and nothing worked.

      3. Chown'd everything in the deploy subfolder to our application group id; although I got some errors, this was yet the closest I got to the desired behavior.

      How do others install jboss? Should the deploy folder be owned by root normally or by an application.war file's group id? Our application is consisted of few war and ear files.