3 Replies Latest reply on Jan 31, 2007 10:25 AM by Peter Johnson

    java.lang.NoClassDefFoundError

    hussain rangwala Newbie

      hey peter
      thanks for your reply it really helped my server is up and running fine...however i get an error when i click on the "submit" button of my web page...can you help me on this ..i am using jboss portal 2.4.0.GA and i have jdk 1.5 installed on my windows XP.....Thanks in advance for your reply

      2007-01-30 11:59:41,025 ERROR [org.apache.catalina.core.ContainerBase.[jboss.web].[localhost].[/SETLAppName].[action]] Servlet.service() for servlet action threw exception
      java.lang.NoClassDefFoundError: com/infosys/j2ee/core/ServiceException
       at java.lang.Class.getDeclaredConstructors0(Native Method)
       at java.lang.Class.privateGetDeclaredConstructors(Class.java:2328)
       at java.lang.Class.getConstructor0(Class.java:2640)
       at java.lang.Class.newInstance0(Class.java:321)
       at java.lang.Class.newInstance(Class.java:303)
       at org.apache.struts.util.RequestUtils.applicationInstance(RequestUtils.java:145)
       at org.apache.struts.action.RequestProcessor.processActionCreate(RequestProcessor.java:282)
       at org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:220)
       at org.apache.portals.bridges.struts.PortletTilesRequestProcessor.process(PortletTilesRequestProcessor.java:50)
       at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1164)
       at org.apache.struts.action.ActionServlet.doPost(ActionServlet.java:415)
       at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
       at javax.servlet.http.HttpServlet.service(HttpServlet.java:810)
       at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:252)
       at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
       at org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:96)
       at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:202)
       at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
       at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:213)
       at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:178)
       at org.jboss.web.tomcat.security.SecurityAssociationValve.invoke(SecurityAssociationValve.java:175)
       at org.jboss.web.tomcat.security.JaccContextValve.invoke(JaccContextValve.java:74)
       at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:126)
       at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105)
       at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:107)
       at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)
       at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:869)
       at org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(Http11BaseProtocol.java:664)
       at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:527)
       at org.apache.tomcat.util.net.MasterSlaveWorkerThread.run(MasterSlaveWorkerThread.java:112)
       at java.lang.Thread.run(Thread.java:595)
      


      Kindly reply as soon as possible
      Thanks and Regards
      Hussain

        • 1. Re: java.lang.NoClassDefFoundError
          Peter Johnson Master

          This has to be a problem in your code, or rather, in the packaging of your code. Somewhere you are referencing the missing class in your code, yet the jar file containing that class is not in your WEB-INF/lib directory. (A google search seems to indicate this class is part of struts.)

          • 2. Re: java.lang.NullPointerException
            hussain rangwala Newbie

            hey peter
            thanx for the reply..i placed the lib under the WEB-INF/lib folder ...however now i get another exception can you help me on this or can you refer me to a site where i can find answers to my questions...thanx again

            exception
            
            javax.servlet.ServletException
             org.apache.struts.action.RequestProcessor.processException(RequestProcessor.java:516)
             org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:423)
             org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:226)
             org.apache.portals.bridges.struts.PortletTilesRequestProcessor.process(PortletTilesRequestProcessor.java:50)
             org.apache.struts.action.ActionServlet.process(ActionServlet.java:1164)
             org.apache.struts.action.ActionServlet.doPost(ActionServlet.java:415)
             javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
             javax.servlet.http.HttpServlet.service(HttpServlet.java:810)
             org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:96)
            
            
            root cause
            
            java.lang.NullPointerException
             com.infosys.j2ee.setlbank.web.actions.QuickViewAction.execute(QuickViewAction.java:83)
             org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:421)
             org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:226)
             org.apache.portals.bridges.struts.PortletTilesRequestProcessor.process(PortletTilesRequestProcessor.java:50)
             org.apache.struts.action.ActionServlet.process(ActionServlet.java:1164)
             org.apache.struts.action.ActionServlet.doPost(ActionServlet.java:415)
             javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
             javax.servlet.http.HttpServlet.service(HttpServlet.java:810)
             org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:96)
            
            
            note The full stack trace of the root cause is available in the Apache Tomcat/5.5.17 logs.
            
            
            --------------------------------------------------------------------------------
            
            Apache Tomcat/5.5.17
            

            Thanks
            hussain

            • 3. Re: java.lang.NoClassDefFoundError
              Peter Johnson Master

              I do not recognize the package com.infosys.j2ee. It is not part of JBoss. It is not part of Struts (which I assumed based on a few google hits I got and from the class name). I could not find it in my local Maven repository either. So it must be your package, or one that you got from somewhere. So it is a problem that you will have to fix.