4 Replies Latest reply on Feb 19, 2007 1:29 AM by Bipin Thakur

    java.util.Properties$LineReader.readLine(Properties.java:365

    Bipin Thakur Newbie

      Hi,

      I am using JBOSS AS405 and JDK1.5.0_06. The piece of code works fine when put into a main program and run as a Java application through eclipse IDE. The same code is a part of an enterprise project which has no errors and builds fine. However when i publish the project to the app server, and provide parameters through JMX console, it throws following exception:

      *******************************
      10:56:59,616 ERROR [STDERR] java.lang.NullPointerException
      10:56:59,616 ERROR [STDERR] at java.util.Properties$LineReader.readLine(Properties.java:365)
      10:56:59,616 ERROR [STDERR] at java.util.Properties.load(Properties.java:293)
      *******************************
      Kindly let me know if you have encountered this error before. Your help is highly appreciated.
      Thanks and regards,
      Bipin

        • 1. Re: java.util.Properties$LineReader.readLine(Properties.java
          Elias Ross Master

          Probably the argument to "load()" was a null stream. I would check the args for your call to this and your classpath.

          • 2. Re: java.util.Properties$LineReader.readLine(Properties.java
            Bipin Thakur Newbie

             

            "genman" wrote:
            Probably the argument to "load()" was a null stream. I would check the args for your call to this and your classpath.

            Thanks a lot for your kind reply.
            A have tried with many addtions in the classpath variable. Kindly let me know if any special entry is missing my classpath declaration. current Classpath is :- ;C:\Bipin\JDK\1.5.0_05;C:\Bipin\jboss405GA\;C:\Bipin\jboss405GA\server\lib\;c:\Bipin\jboss405GA\client\; c:\Bipin\myprojects\EJB\assemble\interest_client.jar;c:\Program Files\datastudio\lib;c:\bipin\rv;C:\Bipin\netbeans-5.5\enterprise3\modules

            The argument to load is valid and the same piece of code works perfectly when run through a JBOSS IDE main java program.
            The initial initialization shows below screen:
            C:\Bipin\jboss405GA\bin>run
            ===============================================================================

            JBoss Bootstrap Environment

            JBOSS_HOME: C:\Bipin\jboss405GA\bin\\..

            JAVA: C:\Bipin\JDK\1.5.0_05\bin\java

            JAVA_OPTS: -Dprogram.name=run.bat -Xms128m -Xmx512m -Dsun.rmi.dgc.client.gcInterval=3600000 -Dsun
            .rmi.dgc.server.gcInterval=3600000

            CLASSPATH: C:\Bipin\JDK\1.5.0_05\lib\tools.jar;C:\Bipin\jboss405GA\bin\\run.jar

            ===============================================================================

            16:16:39,170 INFO [Server] Starting JBoss (MX MicroKernel)...
            16:16:39,170 INFO [Server] Release ID: JBoss [Zion] 4.0.5.GA (build: CVSTag=Branch_4_0 date=2006101
            62339)
            16:16:39,170 INFO [Server] Home Dir: C:\Bipin\jboss405GA
            16:16:39,170 INFO [Server] Home URL: file:/C:/Bipin/jboss405GA/
            16:16:39,170 INFO [Server] Patch URL: null
            16:16:39,170 INFO [Server] Server Name: default
            16:16:39,170 INFO [Server] Server Home Dir: C:\Bipin\jboss405GA\server\default
            16:16:39,170 INFO [Server] Server Home URL: file:/C:/Bipin/jboss405GA/server/default/
            16:16:39,170 INFO [Server] Server Log Dir: C:\Bipin\jboss405GA\server\default\log
            16:16:39,170 INFO [Server] Server Temp Dir: C:\Bipin\jboss405GA\server\default\tmp
            16:16:39,186 INFO [Server] Root Deployment Filename: jboss-service.xml
            16:16:39,483 INFO [ServerInfo] Java version: 1.5.0,Sun Microsystems Inc.
            16:16:39,483 INFO [ServerInfo] Java VM: Java HotSpot(TM) Client VM 1.5.0-b64,Sun Microsystems Inc.
            16:16:39,483 INFO [ServerInfo] OS-System: Windows XP 5.1,x86

            Sincere regards,
            Bipin

            • 3. Re: java.util.Properties$LineReader.readLine(Properties.java
              jaikiran pai Master

              Post the piece of code where you are loading the properties file. Also where have you placed the properties file in your webapplication deployed in JBoss?

              • 4. Re: java.util.Properties$LineReader.readLine(Properties.java
                Bipin Thakur Newbie

                Thanks a lot everybody. I got my issue resolved. I created JBOSS_CLASSPATH env variable and added classpaths to this. Finally it ran as expected.
                Thanks again for all the help.
                Regards,
                Bipin