3 Replies Latest reply on Oct 30, 2007 1:52 AM by jaikiran pai

    axis 1.4 on jboss 4.0.5

    Guenter Neumann Newbie

      hi!
      I'm trying to set up AXIS on JBoss, but it does not work

      I try the following:
      1. unzip axis
      2. copy axis in $JBOSS_HOME/server/default/deploy
      3. goto http://localhost:8080/axis

      and unfortunately no happy axis page :(

      Can someone give mi a tip?

        • 1. Re: axis 1.4 on jboss 4.0.5
          jaikiran pai Master

          Do you see any exceptions on the console or server.log file when JBoss is starting?

          • 2. Re: axis 1.4 on jboss 4.0.5
            Ibrahim El-Fayoumi Newbie

            Hi, i am getting the same thing, and the exception I get:
            --- Packages waiting for a deployer ---
            org.jboss.deployment.DeploymentInfo@afd78858 { url=file:/usr/local/jboss-4.0.5.GA/server/default/deploy/webapps/axis/EchoHeaders.jws }
            deployer: null
            status: null
            state: INIT_WAITING_DEPLOYER
            watch: file:/home/usr/local/jboss-4.0.5.GA/server/default/deploy/webapps/axis/EchoHeaders.jws
            altDD: null
            lastDeployed: 1193715867969
            lastModified: 1193715867000
            mbeans:

            Thanks,
            Ibrahim

            • 3. Re: axis 1.4 on jboss 4.0.5
              jaikiran pai Master

               

              file:/home/usr/local/jboss-4.0.5.GA/server/default/deploy/webapps/axis/EchoHeaders.jws


              Looks like you have incorrectly deployed Axis in JBoss. When you download Axis, it comes with a webapps folder which contains a axis sub-folder. For deploying Axis in JBoss, you will have to copy the axis folder (and NOT the webapps folder) to the server/default/deploy folder of JBoss. Once you have done that, you will have to rename axis in the server/default/deploy to axis.war for it to be deployed by JBoss.

              P.S: There are chances that you will see exceptions when JBoss is deploying axis. This will have to do with the commons-logging and log4j related jar files present in the axis/WEB-INF/lib folder. So, if you run into such an exception, just delete the commons-loggingxxx.jar and log4jxx.jar from the axis.war/WEB-INF/lib folder and restart JBoss