2 Replies Latest reply on May 9, 2007 1:35 PM by shivang vyas

    jboss-4.0.5.GA+Windows Vista Home Premium+C:\Java\jdk1.5.0_1

    shivang vyas Newbie

      I am trying to install JBoss application server on my laptop which has Windows Vista Home Premium. I downloaded the jboss-4.0.5.GA.zip from the jboss website and extracted on my C drive at C:\jboss-4.0.5.GA and jdk1.5.0_11 installed at C:\Java\jdk1.5.0_11. JBOSS_HOME & JAVA_HOME have been set to the afore mentioned locations respectively. Now I tried running the server ( using the run.bat file under the bin directory)and it booted up successfully. Following is the mesg at command prompt:
      16:03:50,477 INFO [DLQ] Bound to JNDI name: queue/DLQ
      16:03:50,852 INFO [ConnectionFactoryBindingService] Bound ConnectionManager 'jb
      oss.jca:service=ConnectionFactoryBinding,name=JmsXA' to JNDI name 'java:JmsXA'
      16:03:51,004 INFO [TomcatDeployer] deploy, ctxPath=/jmx-console, warUrl=.../dep
      loy/jmx-console.war/
      16:03:51,714 INFO [Http11BaseProtocol] Starting Coyote HTTP/1.1 on http-0.0.0.0
      -8080
      16:03:51,861 INFO [ChannelSocket] JK: ajp13 listening on /0.0.0.0:8009
      16:03:51,882 INFO [JkMain] Jk running ID=0 time=0/50 config=null
      16:03:51,891 INFO [Server] JBoss (MX MicroKernel) [4.0.5.GA (build: CVSTag=Bran
      ch_4_0 date=200610162339)] Started in 20s:270ms

      However, When I try to bring up the console ( http://localhost:8080/jmx-console/), I get the following exception everytime.
      16:04:24,926 ERROR [PoolTcpEndpoint] Endpoint ServerSocket[addr=/0.0.0.0,port=0,
      localport=8080] ignored exception: java.net.SocketException: select failed
      java.net.SocketException: select failed
      at java.net.PlainSocketImpl.socketAccept(Native Method)
      at java.net.PlainSocketImpl.accept(PlainSocketImpl.java:384)
      at java.net.ServerSocket.implAccept(ServerSocket.java:450)
      at java.net.ServerSocket.accept(ServerSocket.java:421)
      at org.apache.tomcat.util.net.DefaultServerSocketFactory.acceptSocket(De
      faultServerSocketFactory.java:60)
      at org.apache.tomcat.util.net.PoolTcpEndpoint.acceptSocket(PoolTcpEndpoi
      nt.java:407)
      at org.apache.tomcat.util.net.PoolTcpEndpoint.run(PoolTcpEndpoint.java:6
      47)
      at java.lang.Thread.run(Thread.java:595)
      16:04:24,986 WARN [PoolTcpEndpoint] Reinitializing ServerSocket


      Please help me figure out if I am missing something here. I followed the same steps on my PC which has Windows XP Home + jdk1.5.0_11 and it works perfectly fine.
      Someone suggested that this issue can be resolved by uninstalling IPv6. I did that too for both LAN and wireless Network. I also verified tht port 8080 was not in use before I start JBoss.
      I also tried using jboss-3.2.4 and jboss-3.2.8 but same results. Any help in this regard will be appreciated. Thanks in advance.