1 Reply Latest reply on May 21, 2007 7:28 AM by Edwin Rivera

    Help Deploying .war :: javax.xml.ws.WebServiceException

    Edwin Rivera Newbie

      Hello all,

      I've used Netbeans v5.5 IDE w/JBoss 4.0.5-GA running on my desktop to create a simple web service that works great on my desktop PC (JAX-WS).

      I then installed JBoss-4.0.5-GA on a linux box (using same JDK version) and set up my Oracle datasource on the linux box. Jboss starts up great, no errors.

      I then tried to drop the .war file in my dist folder on my PC into the $JBOSS_HOME/server/default/deploy folder

      Jboss server.log file shows it pick up the .war file and read the wsdl descriptor. i can even telnet directly to my jboss port and manually type a GET request that returns the wsdl file.

      that's about as far as i'm able to get though.

      if i try to create a web service client to consume the service, i keep getting the following exception when i try to run it (i does successfully build a reference to the service though):

      Compiling 6 source files to C:\JBossProjects\JavaApplication27\build\classes
      compile:
      run:
      javax.xml.ws.WebServiceException: HTTP Status-Code 404: Not Found - Not Found
      at com.sun.xml.ws.util.SOAPConnectionUtil.getSOAPMessage(SOAPConnectionUtil.java:81)
      at com.sun.xml.ws.encoding.soap.client.SOAPXMLDecoder.toSOAPMessage(SOAPXMLDecoder.java:100)
      at com.sun.xml.ws.protocol.soap.client.SOAPMessageDispatcher.receive(SOAPMessageDispatcher.java:438)
      at com.sun.xml.ws.protocol.soap.client.SOAPMessageDispatcher.doSend(SOAPMessageDispatcher.java:258)
      at com.sun.xml.ws.protocol.soap.client.SOAPMessageDispatcher.send(SOAPMessageDispatcher.java:137)
      at com.sun.xml.ws.encoding.soap.internal.DelegateBase.send(DelegateBase.java:84)
      at com.sun.xml.ws.client.EndpointIFInvocationHandler.implementSEIMethod(EndpointIFInvocationHandler.java:172)
      at com.sun.xml.ws.client.EndpointIFInvocationHandler.invoke(EndpointIFInvocationHandler.java:106)
      at $Proxy16.byUseridShort(Unknown Source)
      at javaapplication27.Main.main(Main.java:43)
      Caused by: HTTP Status-Code 404: Not Found - Not Found
      at com.sun.xml.ws.transport.http.client.HttpClientTransport.checkResponseCode(HttpClientTransport.java:290)
      at com.sun.xml.ws.transport.http.client.HttpClientTransport.getHeaders(HttpClientTransport.java:158)
      at com.sun.xml.ws.util.SOAPConnectionUtil.getSOAPMessage(SOAPConnectionUtil.java:57)
      ... 9 more
      BUILD SUCCESSFUL (total time: 3 seconds)



      This happens both if i try to create the service running netbeans straight off the linux box and using localhost, or whether i try to access the service from my local netbeans install on my pc.

      The part where it builds the service reference works great. it's just when i try to access it that i get the error.

      fwiw, i did an "all" installation on my PC, and an "EJB3" install on the linux server.

      Thanks in advance for your help everyone.

      I'm so close i can almost taste it!