4 Replies Latest reply on Jun 12, 2007 8:23 AM by Poyan Gerami

    Setteing the http port from (8080 ... the default value) to

    Taud Anas Newbie

      I install jboss-4.2.0.GA [default] server and need to set the http port from (8080 ... the default value) to 80.

      I set JBOSS_HOME/server/default/deploy/jboss-web.deployer/server.xml:
      <!-- <Connector port="8080" address="${jboss.bind.address}" ... -->
      <Connector port="80" address="${jboss.bind.address}" ...

      I restart the server, but when I do http://mydomain/ in the browser, it does not work.

      I stop jboss-.4.2.0.GA server ans start an Apache server, when I do http://mydomain/ , il works.


      Is there more setting to do in jboss-4.2.0.GA ?

        • 1. Re: Setteing the http port from (8080 ... the default value)
          Sergey Sudakovich Newbie

          In the same exact file you will find something like this:

          <Host name="localhost">
          


          that is the name of the host - change it to mydomain and you are almost done. In the Engine tag change the default to mydomain and restart.


          • 2. Re: Setteing the http port from (8080 ... the default value)
            Taud Anas Newbie

            I need to configure 2 virtual hosts (mydomain1.com and mydomain2.com).
            I write in JBOSS_HOME/server/default/deploy/jboss-web.deployer/server.xml:

            ....
            <Connector port="80" address="the IP adress" ...protocol="HTTP/1.1".../>
            <Connector port="8009" .... protocol="AJP/1.3"... />
            <Enginee name="jboss.web" defaultHost="mydomain1.com">
            <Realm className="org.jboss.web.tomcat.security.JBossSecurityMgrRealm".../>
            
            <Host name="mydomain1.com" autoDeploy="false"
             deployOnStartup="false" deployXML="false"
             configClass="org.jboss.web.tomcat.security.config.JBossContextConfig">
             <Alias>www.mydomain1.com</Alias>
             <Valve className="org.jboss.web.tomcat.service.jca.CachedConnectionValve"
             cachedConnectionManagerObjectName="jboss.jca:service=CachedConnectionManager"
             transactionManagerObjectName="jboss:service=TransactionManager" />
            </Host>
            
            <Host name="mydomain2.com" autoDeploy="false"
             deployOnStartup="false" deployXML="false"
             configClass="org.jboss.web.tomcat.security.config.JBossContextConfig">
             <Alias>www.mydomain2.com</Alias>
             <Valve className="org.jboss.web.tomcat.service.jca.CachedConnectionValve"
             cachedConnectionManagerObjectName="jboss.jca:service=CachedConnectionManager"
             transactionManagerObjectName="jboss:service=TransactionManager" />
            </Host>
            
            </Engine>
            


            I deploy mydomain1.war containing:
            - jboss-web.xml
            <jboss-web>
            <context-root>/mydomain1</context-root>
            <virtual-host>mydomain1.com</virtual-host>
            </jboss-web>
            

            - index.jsp
            ...
            <body>
            wellcome to mydomain1.com
            </body>
            ...
            


            I deploy mydomain2.war containing:
            - jboss-web.xml
            <jboss-web>
            <context-root>/mydomain2</context-root>
            <virtual-host>mydomain2.com</virtual-host>
            </jboss-web>
            

            - index.jsp
            ..
            <body>
            wellcome to mydomain2.com
            </body>
            ...
            


            But when I populate www.mydomain1.com and www.mydomain2.com in the browser I obtain an empty page !!!



            • 3. Re: Setteing the http port from (8080 ... the default value)
              Poyan Gerami Novice

              i have a simular problem in 4.2.0GA
              i start my jboss with

              run.sh -c all -b mydomain


              i change in server.xml:

              <Connector port="8480" address="${jboss.bind.address}"

              <Engine name="jboss.web" defaultHost="mydomain">
              

              <Host name="mydomain"
              


              i still can not access http://mydomain:8480
              i can telnet to it and it answer
              telnet mysomain 8480





              • 4. Re: Setteing the http port from (8080 ... the default value)
                Poyan Gerami Novice

                i most add that i also use bindingmanager service