1 Reply Latest reply on Jun 19, 2007 7:51 PM by Taud Anas

    Problem when configuring virtual hosts in jboss-4.2.0.GA

    Taud Anas Newbie

      I need to configure 2 virtual hosts (mydomain1.com and mydomain2.com).
      I write in JBOSS_HOME/server/default/deploy/jboss-web.deployer/server.xml:

      ....
      <Connector port="80" address="the IP adress" ...protocol="HTTP/1.1".../>
      <Connector port="8009" .... protocol="AJP/1.3"... />
      <Enginee name="jboss.web" defaultHost="mydomain1.com">
      <Realm className="org.jboss.web.tomcat.security.JBossSecurityMgrRealm".../>
      
      <Host name="mydomain1.com" autoDeploy="false"
       deployOnStartup="false" deployXML="false"
       configClass="org.jboss.web.tomcat.security.config.JBossContextConfig">
       <Alias>www.mydomain1.com</Alias>
       <Valve className="org.jboss.web.tomcat.service.jca.CachedConnectionValve"
       cachedConnectionManagerObjectName="jboss.jca:service=CachedConnectionManager"
       transactionManagerObjectName="jboss:service=TransactionManager" />
      </Host>
      
      <Host name="mydomain2.com" autoDeploy="false"
       deployOnStartup="false" deployXML="false"
       configClass="org.jboss.web.tomcat.security.config.JBossContextConfig">
       <Alias>www.mydomain2.com</Alias>
       <Valve className="org.jboss.web.tomcat.service.jca.CachedConnectionValve"
       cachedConnectionManagerObjectName="jboss.jca:service=CachedConnectionManager"
       transactionManagerObjectName="jboss:service=TransactionManager" />
      </Host>
      
      </Engine>
      


      I deploy mydomain1.war containing :
      - jboss-web.xml
      <context-root>/mydomain1</context-root>
      <virtual-host>mydomain1.com</virtual-host>
      </jboss-web>
      

      - index.jsp
      <body>
      wellcome to mydomain1.com
      </body>
      ...
      


      I deploy mydomain2.war containing :
      - jboss-web.xml
      <context-root>/mydomain2</context-root>
      <virtual-host>mydomain2.com</virtual-host>
      </jboss-web>
      

      - index.jsp
      <body>
      wellcome to mydomain2.com
      </body>
      ...
      


      But when I populate www.mydomain1.com and www.mydomain2.com in the browser I obtain an empty page !!!