0 Replies Latest reply on Jul 9, 2007 5:08 PM by Brian Something

    UnsatisfiedLinkError with third-party DLL

    Brian Something Newbie

      Hi all,

      I'm developing an application on JBoss that uses a third-party DLL utility accessed through the third-party's Java API. Both of these are proprietary and I have no control over their content.

      When my application tries to use the API, I get an UnsatisfiedLinkError with the following stack trace:

      ...
      16:15:56,642 ERROR [STDERR] Caused by: java.lang.UnsatisfiedLinkError: ThirdPartyMethod
      16:15:56,642 ERROR [STDERR] at third.party.PrivateClass.ThirdPartyMethod(Native Method)
      16:15:56,642 ERROR [STDERR] at third.party.ThirdPartyClass.privateMethod(ThirdPartyClass.java:152)
      16:15:56,642 ERROR [STDERR] at third.party.ThirdPartyClass.<init>(ThirdPartyClass.java:85)
      ...
      


      I *KNOW* that I am loading the third party DLLs fine, because if I remove them from my system, I get an "UnsatisfiedLinkError: no ThirdPartyLibrary in java.library.path".

      My problem is basically the same as the problem described in http://www.jboss.org/index.html?module=bb&op=viewtopic&t=68428&postdays=0&postorder=asc&start=0 JBoss forum post:

      However, I tried to implement the solution described there and it didn't work. I get the exact same error. Could someone maybe elaborate more fully on the solution described in that post?

      Any hints would be greatly appreciated!

      For the record, I am developing on Windows XP SP2 with Java 1.5, JBoss 4.0.4, and EJB 3.0.