1 Reply Latest reply on Oct 12, 2007 4:04 AM by Bruno Jost

    HSQLDB troubles with JBoss 4 in Unix System Services on zOS

    Bruno Jost Newbie

      Hi JBoss-Gurus

      I tried to install a JBoss 4.0.4, 4.0.5 and 4.2 on a UNIX System Service on zOS.
      The installation itself is successfull. after some troubles with EBCDIC/ASCII JBoss seems to start - until HSQLDB...
      ...
      09:10:46,579 INFO [WrapperDataSourceService] Bound ConnectionManager 'jboss.jca:service=DataSourceBinding,name=DefaultDS' to JNDI '
      09:10:57,165 WARN [ServiceController] Problem starting service jboss.mq:service=PersistenceManager
      org.jboss.mq.SpyJMSException: Could not resolve uncommited transactions. Message recovery may not be accurate; - nested throwable:)
      ...
      Caused by:
      java.sql.SQLException: Column not found: TXID in statement [SELECT MAX(TXID) FROM (SELECT MAX(TXID) FROM JMS_TRANSACTIONS UNION SEL]
      ...

      Installation methods:
      I installed JBoss with the installer, tried the zip-file from the download-page, and even a copy of a running Linux-installation has the same HSQLDB-error while starting!

      Is there anyone who has solved this issue or knows a solution?

      Thanks, Bruno