5 Replies Latest reply on Jul 19, 2007 5:53 AM by Adrian Pillinger

    Class loader isolation broken in 4.2.0GA

    Adrian Pillinger Newbie

      I have an application (ear) that was running on 4.0.5 and contained a jboss-app.xml in the ear's META-INF directory. This worked perfectly alongside our other application.

      <jboss-app>
      <loader-repository>dot.com:loader=imhist-server-deploy</loader-repository>
      </jboss-app>


      I have tried to migrate this application to 4.2.0GA and when the server boots it gives the following warning

      14:56:21,803 WARN [DeploymentInfo] Only the root deployment can set the loader repository, ignoring config=LoaderRepositoryConfig(repositoryName: dot.com:loader=imhist-server-deploy, repositoryClassName: org.jboss.mx.loading.HeirarchicalLoaderRepository3, configParserClassName: null, repositoryConfig: null)
      


      Looking in the 4.2.0 jmx console there is no longer an entry for the dot.com loader named imhist-server-deploy as appeared in 4.0.5.

      Now when I deploy our other application it fails to deploy due to the class isolation not working.

      Is this a 4.2.0GA bug or has there been a change in configuration?

      Any help would be greatly appreciated