4 Replies Latest reply on Aug 6, 2007 7:58 AM by Stefan Hausch

    Update to jdk 1.5.0_12 causes package does not exists in sar

    Evandro Agnes Newbie

      I have jboss 4.0.1sp1 running under jdk 1.5.0_06. When I update to jdk 1.5.0_12 (ou 11), my ear application don't find a package in the sar or har file. The error occurs in jsp file compilation:

      2007-07-30 11:08:23,816 ERROR [org.apache.jasper.compiler.Compiler] Error compiling file: /D:/Desenv/jboss-4.0.1sp1/server/local/work/jboss.web/localhost/app//org/apache/jsp/decorators\default_jsp.java [javac] Compiling 1 source file

      D:\Desenv\jboss-4.0.1sp1\server\local\work\jboss.web\localhost\app\org\apache\jsp\decorators\default_jsp.java:6: package com.app.model.beans does not exist
      import com.app.model.beans.Constants;
      ^
      Note: D:\Desenv\jboss-4.0.1sp1\server\local\work\jboss.web\localhost\app\org\apache\jsp\decorators\default_jsp.java uses unchecked or unsafe operations.
      Note: Recompile with -Xlint:unchecked for details.
      1 error


      My applications:
      app.ear
      |-app.jar
      |-app.war

      app.sar

      Sorry for english...