0 Replies Latest reply on Aug 1, 2007 10:00 AM by John Wooten

    seam example will not deploy

    John Wooten Newbie

      Installed using jems installer the JBoss-4.0.5.GA. Selected the full installation ( tried just the ejb and that didn't work either ).

      Installed the jboss-seam-1.2.1.GA.

      This is Mac OS X 10.4.10 so edited the build.properties to point to my tomcat.home and my jboss.home.

      cd'd to examples/booking and did ant deploy. No errors! it copied ear file to JBoss.*/server/deploy.

      Started JBoss server via bin/run.sh

      I get
      --- Incompletely deployed packages ---
      org.jboss.deployment.DeploymentInfo@7ae9c196 { url=file:/Applications/jboss-4.0.5.GA/server/default/deploy/jboss-seam-registration.ear }
      deployer: org.jboss.deployment.EARDeployer@10ad7e
      status: Deployment FAILED reason: ejb-jar.xml must either obey the right xml schema or define a valid DOCTYPE!
      state: FAILED
      watch: file:/Applications/jboss-4.0.5.GA/server/default/deploy/jboss-seam-registration.ear
      altDD: null
      lastDeployed: 1185976224917
      lastModified: 1185976224000
      mbeans:

      WHY does the ejc-jar.xml not have the correct information?

      How do I correct this? I want to get the first example working. booking doesn't work either and gives the same error.