2 Replies Latest reply on Aug 18, 2007 8:05 PM by jo raksit

    EJB deployer not initialising, and getting upset about non-e

    jo raksit Newbie

      hello

      i've installed jboss, and i've got oracle xe as my datasource configured too. i'm using jdk 6 & jre 6 and i'm running win xp pro sp2. i've been tring to deploy an ejb jar, but when i place it in my deploy foldder, nothing happpens, my cmd line does not register it. i've put sample .ear files in the directory and it gets registered/triesto deply but nothing with my jar files.

      bizzarely when i unzip my jar files in the deploy directory (to check i've got everythin in them) - then i get errror messsages eg.

      org.jboss.deployment.DeploymentInfo@ec397f54 { url=file:/C:/JBOSS/server/default
      /deploy/ejb/com/AVman/Audiorec/AVmanRemote.class }
      deployer: null
      status: null
      state: INIT_WAITING_DEPLOYER
      watch: file:/C:/JBOSS/server/default/deploy/ejb/com/AVman/Audiorec/AVmanRemote
      .class
      altDD: null
      lastDeployed: 1187276293656
      lastModified: 1187276293656
      mbeans:


      but now what's happening when i start jboss with nothing extra in my deploy directory are these messages:


      19:04:35,609 INFO [WrapperDataSourceService] Bound ConnectionManager 'jboss.jca
      :service=DataSourceBinding,name=XAOracleDS' to JNDI name 'java:XAOracleDS'
      19:04:35,765 INFO [TomcatDeployer] deploy, ctxPath=/jmx-console, warUrl=.../dep
      loy/jmx-console.war/
      19:04:36,578 ERROR [URLDeploymentScanner] Incomplete Deployment listing:

      --- Packages waiting for a deployer ---
      org.jboss.deployment.DeploymentInfo@386bee7e { url=file:/C:/JBOSS/server/default
      /deploy/Desktop.ini }
      deployer: null
      status: null
      state: INIT_WAITING_DEPLOYER
      watch: file:/C:/JBOSS/server/default/deploy/Desktop.ini
      altDD: null
      lastDeployed: 1187460276562
      lastModified: 1187460276531
      mbeans:

      org.jboss.deployment.DeploymentInfo@bba1ea5b { url=file:/C:/JBOSS/server/default
      /deploy/Thumbs.db }
      deployer: null
      status: null
      state: INIT_WAITING_DEPLOYER
      watch: file:/C:/JBOSS/server/default/deploy/Thumbs.db
      altDD: null
      lastDeployed: 1187460276578
      lastModified: 1187460276562
      mbeans:

      --- Incompletely deployed packages ---
      org.jboss.deployment.DeploymentInfo@386bee7e { url=file:/C:/JBOSS/server/default
      /deploy/Desktop.ini }
      deployer: null
      status: null
      state: INIT_WAITING_DEPLOYER
      watch: file:/C:/JBOSS/server/default/deploy/Desktop.ini
      altDD: null
      lastDeployed: 1187460276562
      lastModified: 1187460276531
      mbeans:

      org.jboss.deployment.DeploymentInfo@bba1ea5b { url=file:/C:/JBOSS/server/default
      /deploy/Thumbs.db }
      deployer: null
      status: null
      state: INIT_WAITING_DEPLOYER
      watch: file:/C:/JBOSS/server/default/deploy/Thumbs.db
      altDD: null
      lastDeployed: 1187460276578
      lastModified: 1187460276562
      mbeans:


      19:04:36,968 INFO [Http11BaseProtocol] Starting Coyote HTTP/1.1 on http-0.0.0.0
      -8081
      19:04:37,437 INFO [ChannelSocket] Port busy 8009 java.net.BindException: Addres
      s already in use: JVM_Bind
      19:04:37,500 INFO [ChannelSocket] JK: ajp13 listening on /0.0.0.0:8010
      19:04:37,531 INFO [JkMain] Jk running ID=1 time=0/188 config=null
      19:04:37,609 INFO [Server] JBoss (MX MicroKernel) [4.0.5.GA (build: CVSTag=Bran
      ch_4_0 date=200610162339)] Started in 41s:188ms



      as well as the other error messages when i unzip a jar into the deploy directory

      firstly, the problem files my new error messages refer to, i cannt find in the deploy directory (ie. thumbs.db)

      and from what i can decipher, i do not have a deployer, or it doesnt initialise? how can i verify and resolve this?

      from my searches, its once been mentioned java6 being a problem? but my hunch is that its the deployer?

      any ideas?

        • 1. Re: EJB deployer not initialising, and getting upset about n
          jaikiran pai Master

           

          "Jihnd" wrote:
          i've been tring to deploy an ejb jar, but when i place it in my deploy foldder, nothing happpens,


          What does the jar contain? Does it have a META-INF folder with ejb-jar.xml file?

          As far as the Desktop.ini and thumbs.db files are concerned, these usually show up as "hidden" files. Looks like the deploy folder has these files. Go to your windows folder options and enable the option to see hidden files. Then delete these files from the deploy folder

          • 2. Re: EJB deployer not initialising, and getting upset about n
            jo raksit Newbie

            jaikiran, thanks, i don't have aan ejb-jar.xml file. i'm referring to the bill burke ejb3 book and contained examples, and there is no ejb-jar.xml file there;

            so i googled ejb3 jarstructure and came across this post; http://www.jboss.org/?module=bb&op=viewtopic&t=103680
            which states it is not needed if you're using annotations which i am

            so then i reviewed my jar file structure and found that my persistence.xml file (which i believe is the only configuration file needed in the jar) was misplaced

            reshuffled and built a new jar and hey presto, it's recognised!

            (recongised by a scrolling of "java.sql.SQLException: Io exception: The Network Adapter could not establish the connection" errors in the cmd line, but hey, it's recognised, it's progress!)

            thanks for the tip off :)