0 Replies Latest reply on Aug 20, 2007 3:29 PM by Sen

    How can packages inside JBoss use libraries outside JBoss?

    Sen Newbie

      Hello all,

      JBoss AS: 4.0.5.GA
      JBoss AOP: 1.5.5.GA
      JDK: 1.5.0.12
      OS: XP
      J2EE Application I am deploying: TPC-W

      I have successfully deployed TPC-W on JBoss AS and it worked perfectly well. Then I tried to add a new class called "DecisionMaker" (DM) into it. The "DM" class will make some self-adaptive decisions at the run-time. Inside the "DM" class, I imported IBM ABLE library and setup the ABLE's classpath as "Environment Variable". The new TPC-W compiled and deployed with no problems.

      However, at the runtime, once the DM class needs to use ABLE library, the console will print out the "NoClassDefFoundError" exception. The JBoss didn't load the ABLE library.

      I read through some documentations on the JBoss website. It seems like I got the dynamic classloading problem. What configurations should I do to make JBoss loads my external libraries?

      Thank you very much!