2 Replies Latest reply on Oct 3, 2007 2:15 PM by Przemyslaw Rudzki

    JBoss AS 4.2.1 with SSL with Tomcat Native on Linux

    Przemyslaw Rudzki Newbie

      Hi,

      1. I have done this: http://wiki.jboss.org/wiki/Wiki.jsp?page=HowToAddAprToJBoss

      2. Then this:

      <Connector port="443" maxHttpHeaderSize="8192"
       maxThreads="50" enableLookups="false" disableUploadTimeout="true"
       acceptCount="100" scheme="https" secure="true"
       SSLEngine="on" address="${jboss.bind.address}"
       SSLCertificateFile="/home/erace/localhost.crt"
       SSLCertificateKeyFile="/home/erace/localhost.key"/>


      3. When JBoss AS starts I get this:
      ...
      18:18:44,306 INFO [AprLifecycleListener] Loaded Apache Tomcat Native library 1.1.11.
      18:18:44,306 INFO [AprLifecycleListener] APR capabilities: IPv6 [true], sendfile [true], accept filters [false], random [true].
      ...
      18:19:02,043 INFO [Http11AprProtocol] Starting Coyote HTTP/1.1 on http-127.0.0.1-8080
      18:19:02,058 INFO [Http11AprProtocol] Starting Coyote HTTP/1.1 on http-127.0.0.1-443
      18:19:02,068 INFO [AjpAprProtocol] Starting Coyote AJP/1.3 on ajp-127.0.0.1-8009
      18:19:02,079 INFO [Server] JBoss (MX MicroKernel) [4.2.1.GA (build: SVNTag=JBoss_4_2_1_GA date=200707131605)] Started in 24s:903ms


      4. When I connect to https://localhost I get nothing.

      5. When I connect on http://localhost:443 I get welcome page.

      Have anybody managed to run the mentioned configuration so it actually works as it suppose to?

      Is there any way to increase verbosity in logging that will show me what happens during start of the connectors?

      Rgds,

      /p