0 Replies Latest reply on Oct 6, 2007 9:05 AM by Michael Clagett

    Need help instaling app into JBoss 4.2.0GA

    Michael Clagett Newbie

      Hi --

      Here is a message I posted on the Jira Forums. I just installed Jira in JBoss 4.2.0 and have encountered an issue, which I outline in the message below. It was suggested to me that perhaps I haven't done enough to tell JBoss there is a Jira app deployed at lcalhost:8080/Jira.

      If anybody has any thoughts, I'd be greatly appreciative.

      Here's the message:


      Hi --

      I just tried to do an install of Jira into JBoss 4.2.0GA (with integrated Tomcat). Not sure if I followed the instructions correctly, but briefly i did the following:

      1) Downloaded ojdbc14.jar from Oracle and placed it into JBoss's server/default/deploy/lib folder

      2) created a jira-ds.xml and placed it into JBoss's server/deploy folder. It's short enough that I feel okay including it here:

      <?xml version="1.0" encoding="UTF-8"?>
      <!-- DataSource for JIRA webapp,
      called 'JiraDS' (must be same in entityengine.xml) -->

      <local-tx-datasource>
      <jndi-name>JiraDS</jndi-name>
      <connection-url>jdbc:oracle:thin:@localhost:1521:jiradb</connection-url>
      <driver-class>oracle.jdbc.driver.OracleDriver</driver-class>
      <user-name>jirauser</user-name>
      jirauser
      </local-tx-datasource>


      3) Downloaded the Jira WAR distribution and edited the entityengine.xml in edit-webapp\WEB-INF\classes

      Again the changes are small enough that I feel okay posting them here:

      <transaction-factory class="org.ofbiz.core.entity.transaction.JNDIFactory">
      <user-transaction-jndi jndi-server-name="default" jndi-name="UserTransaction"/>
      <transaction-manager-jndi jndi-server-name="default" jndi-name="java:TransactionManager"/>
      </transaction-factory>

      And

      <datasource name="defaultDS" field-type-name="oracle10g"
      schema-name="PUBLIC"
      helper-class="org.ofbiz.core.entity.GenericHelperDAO"
      check-on-start="true"
      use-foreign-keys="false"
      use-foreign-key-indices="false"
      check-fks-on-start="false"
      check-fk-indices-on-start="false"
      add-missing-on-start="true"
      check-indices-on-start="true">
      <jndi-jdbc jndi-server-name="default" jndi-name="java:JiraDS"/>
      <!-- Orion format: <jndi-jdbc jndi-server-name="default" jndi-name="jdbc/JiraDS"/> -->
      <!-- JBoss format: <jndi-jdbc jndi-server-name="default" jndi-name="java:/DefaultDS"/> -->
      <!-- Weblogic format: <jndi-jdbc jndi-server-name="default" jndi-name="JiraDS"/> -->


      4) I then built Jira and copied the result WAR file to JBoss's server/default/deploy folder renaming it to Jira.WAR

      5) stopped and restarted JBoss (which I have running as a service on Windows 2003 sp2 server)

      In the server log for JBOSS all indications are that everything it tried to load loaded correctly. No errors or exceptions flagged with any of the Jira stuff

      Also, when I examine JBoss with jmx-console I see four entries for JiraDS -- DataSourceBinding, LocalTxCM, ManagedConnectionFactory, ManagedConnectionPool.

      There are also two entries for:
      J2EEApplication=null,J2EEServer=Local,WebModule=jira.war,j2eeType=Servlet,name=default

      AND

      J2EEApplication=null,J2EEServer=Local,WebModule=jira.war,j2eeType=Servlet,name=jsp

      Yet I am getting a 404 message when I am attempting to connect with http://localhost:8080/jira/

      Does anyone have any ideas for me. It would appear that a lot of this went well, but I'm new to JBoss (and Java altogether, actually) and am not sure what might still be the problem.

      Thank you very much for any help you might provide.

      Regards,

      Mike