2 Replies Latest reply on Nov 30, 2007 8:13 AM by David Naden

    mod_jk works, but only with localhost in the workers.propert

    David Naden Newbie

      JBoss 4.2.0GA
      Apache 2.2.4
      mod_jk 1.2.25

      Following the instructions at http://www.jboss.org/wiki/Wiki.jsp?page=UsingMod_jk1.2WithJBoss, I can get it to work, but ONLY if I use localhost as the machine name in the workers.properties file, like this:

      worker.list=node1,status,loadbalancer
      worker.node1.port=8009
      worker.node1.host=localhost
      worker.node1.type=ajp13
      worker.node1.lbfactor=1

      As soon as I put an actual machine name for host, I get:

      "Service Temporarily Unavailable", and the jk log says:

      [info] jk_ajp_common.c (1265): (node1) all endpoints are disconnected
      [Thu Nov 29 15:31:45 2007][4288:6084] [info] jk_ajp_common.c (2085): (node1) sending request to tomcat failed, recoverable operation attempt=1
      [Thu Nov 29 15:31:46 2007][4288:6084] [info] jk_connect.c (473): connect to 172.16.27.112:8009 failed (errno=61)
      [Thu Nov 29 15:31:46 2007][4288:6084] [info] jk_ajp_common.c (891): Failed opening socket to (172.16.27.112:8009) (errno=61)
      [Thu Nov 29 15:31:46 2007][4288:6084] [info] jk_ajp_common.c (1311): (node1) error connecting to the backend server (errno=61)
      [Thu Nov 29 15:31:46 2007][4288:6084] [info] jk_ajp_common.c (2085): (node1) sending request to tomcat failed, recoverable operation attempt=2
      [Thu Nov 29 15:31:46 2007][4288:6084] [error] jk_ajp_common.c (2097): (node1) Connecting to tomcat failed. Tomcat is probably not started or is listening on the wrong port.

      Can anyone help?
      (jkstatus works fine)

      -Dave Naden