1 Reply Latest reply on Dec 11, 2007 5:45 PM by Sergio

    Jkmount /jmx-console/* not working in Apache

    Sergio Newbie

      My last post is quite lengthy and I think I'll have a better chance at getting an answer for this question, but if somebody can answer my last post I'll be glad or even impressed.
      I have Apache2 and Jboss 4 running on the same machine, when I set

      JkMount /* jboss

      I can get to my http://localhost/jmx-console with no problem, but if I set

      JkMount /jmx-console/* jboss

      in my configuration I get the following error message.


      [Sun Dec 09 23:06:09 2007] [jk_uri_worker_map.c (486)]: Into jk_uri_worker_map_t::map_uri_to_worker
      [Sun Dec 09 23:06:09 2007] [jk_uri_worker_map.c (500)]: Attempting to map URI '/jmx-console'
      [Sun Dec 09 23:06:09 2007] [jk_uri_worker_map.c (618)]: jk_uri_worker_map_t::map_uri_to_worker, done without a match
      [Sun Dec 09 23:06:09 2007] [jk_uri_worker_map.c (486)]: Into jk_uri_worker_map_t::map_uri_to_worker
      [Sun Dec 09 23:06:09 2007] [jk_uri_worker_map.c (500)]: Attempting to map URI '/jmx-console'
      [Sun Dec 09 23:06:09 2007] [jk_uri_worker_map.c (618)]: jk_uri_worker_map_t::map_uri_to_worker, done without a match
      [Sun Dec 09 23:06:09 2007] [jk_uri_worker_map.c (486)]: Into jk_uri_worker_map_t::map_uri_to_worker
      [Sun Dec 09 23:06:09 2007] [jk_uri_worker_map.c (500)]: Attempting to map URI '/error/HTTP_NOT_FOUND.html.var'
      [Sun Dec 09 23:06:09 2007] [jk_uri_worker_map.c (618)]: jk_uri_worker_map_t::map_uri_to_worker, done without a match
      [Sun Dec 09 23:06:09 2007] [jk_uri_worker_map.c (486)]: Into jk_uri_worker_map_t::map_uri_to_worker



      This is my modjk configuration file for apache
      ===============================================
      LoadModule jk_module /usr/lib/apache2/mod_jk.so

      JkWorkersFile /etc/apache2/conf.d/workers.properties
      #JkShmFile /var/log/apache2/mod_jk.shm
      JkLogFile /var/log/apache2/mod_jk.log
      JkLogLevel debug
      JkLogStampFormat "[%a %b %d %H:%M:%S %Y]"
      JkLogLevel debug

      JkMount /* jboss




      This is my workers.properties file
      ==============================================
      worker.list=jboss
      worker.jboss.port=8009
      worker.jboss.host=localhost
      worker.jboss.type=ajp13
      worker.jboss.lbfactor=1


      Any help would be greatly appreciated...

      Here is my last post if anyone is interested.
      http://jboss.org/index.html?module=bb&op=viewtopic&t=125531