2 Replies Latest reply on Jan 10, 2008 2:11 PM by marco aurelio

    HTTP 404 not using localhost

    Sascha Janz Master

      hi,

      i installed jboss on a server. http://localhost:8080/web-console works fine.

      but when i try to call from extern using the ip adress i get http 404

      i installed tomcat on the same server, using the ip adress to access tomcat admin pages...no problem.

      so i got some problem with jboss. any idea what i should check?

        • 1. Re: HTTP 404 not using localhost
          Peter Johnson Master

          Read the readme.html file, first bullet under JBossAS 4.2.0.GA in the Configuration Issues section.

          • 2. Re: HTTP 404 not using localhost
            marco aurelio Newbie

            try this:
            run.sh -b 0.0.0.0
            look in the readme.html :

            "JBossAS 4.2.0.GA
            * JBossAS now binds its services to localhost (127.0.0.1) *by default*, instead of binding to all available interfaces (0.0.0.0). This was primarily done for security reasons because of concerns of users going to production without having secured their servers properly. To enable remote access by binding JBoss services to a particular interface, simply run jboss with the -b option. To bind to all available interfaces and re-enable the legacy behaviour use -b 0.0.0.0. In any case, be aware you still need to secure you server properly. "