1 Reply Latest reply on Dec 28, 2007 11:40 PM by Peter Johnson

    Can't access web-console

    Alex Bourqui Newbie

      Hi,

      I've tried to install JBoss 4.2.2.GA... my server is good starting like this trace :

      [root@localhost bin]# ./run.sh
      =========================================================================
      
       JBoss Bootstrap Environment
      
       JBOSS_HOME: /opt/jboss/jboss-4.2.2.GA
      
       JAVA: /usr/java/jdk1.5.0_14/bin/java
      
       JAVA_OPTS: -Dprogram.name=run.sh -server -Xms128m -Xmx512m -Dsun.rmi.dgc.client.gcInterval=3600000 -Dsun.rmi.dgc.server.gcInterval=3600000 -Djava.net.preferIPv4Stack=true
      
       CLASSPATH: /opt/jboss/jboss-4.2.2.GA/bin/run.jar:/usr/java/jdk1.5.0_14/lib/tools.jar
      
      =========================================================================
      
      21:29:58,988 INFO [Server] Starting JBoss (MX MicroKernel)...
      21:29:58,993 INFO [Server] Release ID: JBoss [Trinity] 4.2.2.GA (build: SVNTag=JBoss_4_2_2_GA date=200710221139)
      21:29:58,999 INFO [Server] Home Dir: /opt/jboss/jboss-4.2.2.GA
      21:29:58,999 INFO [Server] Home URL: file:/opt/jboss/jboss-4.2.2.GA/
      21:29:59,003 INFO [Server] Patch URL: null
      21:29:59,004 INFO [Server] Server Name: default
      21:29:59,004 INFO [Server] Server Home Dir: /opt/jboss/jboss-4.2.2.GA/server/default
      21:29:59,005 INFO [Server] Server Home URL: file:/opt/jboss/jboss-4.2.2.GA/server/default/
      21:29:59,006 INFO [Server] Server Log Dir: /opt/jboss/jboss-4.2.2.GA/server/default/log
      21:29:59,006 INFO [Server] Server Temp Dir: /opt/jboss/jboss-4.2.2.GA/server/default/tmp
      21:29:59,008 INFO [Server] Root Deployment Filename: jboss-service.xml
      21:30:00,168 INFO [ServerInfo] Java version: 1.5.0_14,Sun Microsystems Inc.
      21:30:00,168 INFO [ServerInfo] Java VM: Java HotSpot(TM) Server VM 1.5.0_14-b03,Sun Microsystems Inc.
      21:30:00,168 INFO [ServerInfo] OS-System: Linux 2.6.23.8-34.fc7,i386
      21:30:01,380 INFO [Server] Core system initialized
      21:30:07,028 INFO [WebService] Using RMI server codebase: http://127.0.0.1:8083/
      21:30:07,033 INFO [Log4jService$URLWatchTimerTask] Configuring from URL: resource:jboss-log4j.xml
      21:30:08,622 INFO [TransactionManagerService] JBossTS Transaction Service (JTA version) - JBoss Inc.
      21:30:08,622 INFO [TransactionManagerService] Setting up property manager MBean and JMX layer
      21:30:09,442 INFO [TransactionManagerService] Starting recovery manager
      21:30:09,873 INFO [TransactionManagerService] Recovery manager started
      21:30:09,873 INFO [TransactionManagerService] Binding TransactionManager JNDI Reference
      21:30:19,801 INFO [EJB3Deployer] Starting java:comp multiplexer
      21:30:21,040 INFO [STDOUT] no object for null
      21:30:21,064 INFO [STDOUT] no object for null
      21:30:21,186 INFO [STDOUT] no object for null
      21:30:21,299 INFO [STDOUT] no object for {urn:jboss:bean-deployer}supplyType
      21:30:21,358 INFO [STDOUT] no object for {urn:jboss:bean-deployer}dependsType
      21:30:30,497 INFO [NativeServerConfig] JBoss Web Services - Native
      21:30:30,497 INFO [NativeServerConfig] jbossws-native-2.0.1.SP2 (build=200710210837)
      21:30:33,390 INFO [Embedded] Catalina naming disabled
      21:30:34,151 INFO [AprLifecycleListener] The Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: /usr/java/jdk1.5.0_14/jre/lib/i386/server:/usr/java/jdk1.5.0_14/jre/lib/i386:/usr/java/jdk1.5.0_14/jre/../lib/i386
      21:30:34,583 INFO [Http11Protocol] Initializing Coyote HTTP/1.1 on http-127.0.0.1-8080
      21:30:34,584 INFO [AjpProtocol] Initializing Coyote AJP/1.3 on ajp-127.0.0.1-8009
      21:30:34,584 INFO [Catalina] Initialization processed in 1194 ms
      21:30:34,585 INFO [StandardService] Starting service jboss.web
      21:30:34,587 INFO [StandardEngine] Starting Servlet Engine: JBossWeb/2.0.1.GA
      21:30:34,890 INFO [Catalina] Server startup in 304 ms
      21:30:35,433 INFO [TomcatDeployer] deploy, ctxPath=/, warUrl=.../deploy/jboss-web.deployer/ROOT.war/
      21:30:36,934 INFO [TomcatDeployer] deploy, ctxPath=/invoker, warUrl=.../deploy/http-invoker.sar/invoker.war/
      21:30:37,606 INFO [TomcatDeployer] deploy, ctxPath=/jbossws, warUrl=.../deploy/jbossws.sar/jbossws-context.war/
      21:30:38,023 INFO [TomcatDeployer] deploy, ctxPath=/jbossmq-httpil, warUrl=.../deploy/jms/jbossmq-httpil.sar/jbossmq-httpil.war/
      21:30:41,361 INFO [TomcatDeployer] deploy, ctxPath=/web-console, warUrl=.../deploy/management/console-mgr.sar/web-console.war/
      21:30:43,409 INFO [MailService] Mail Service bound to java:/Mail
      21:30:43,980 INFO [RARDeployment] Required license terms exist, view META-INF/ra.xml in .../deploy/jboss-ha-local-jdbc.rar
      21:30:44,182 INFO [RARDeployment] Required license terms exist, view META-INF/ra.xml in .../deploy/jboss-ha-xa-jdbc.rar
      21:30:44,356 INFO [RARDeployment] Required license terms exist, view META-INF/ra.xml in .../deploy/jboss-local-jdbc.rar
      21:30:44,462 INFO [RARDeployment] Required license terms exist, view META-INF/ra.xml in .../deploy/jboss-xa-jdbc.rar
      21:30:44,648 INFO [RARDeployment] Required license terms exist, view META-INF/ra.xml in .../deploy/jms/jms-ra.rar
      21:30:44,789 INFO [RARDeployment] Required license terms exist, view META-INF/ra.xml in .../deploy/mail-ra.rar
      21:30:44,919 INFO [RARDeployment] Required license terms exist, view META-INF/ra.xml in .../deploy/quartz-ra.rar
      21:30:44,957 INFO [QuartzResourceAdapter] start quartz!!!
      21:30:45,216 INFO [SimpleThreadPool] Job execution threads will use class loader of thread: main
      21:30:45,374 INFO [QuartzScheduler] Quartz Scheduler v.1.5.2 created.
      21:30:45,416 INFO [RAMJobStore] RAMJobStore initialized.
      21:30:45,416 INFO [StdSchedulerFactory] Quartz scheduler 'DefaultQuartzScheduler' initialized from default resource file in Quartz package: 'quartz.properties'
      21:30:45,417 INFO [StdSchedulerFactory] Quartz scheduler version: 1.5.2
      21:30:45,417 INFO [QuartzScheduler] Scheduler DefaultQuartzScheduler_$_NON_CLUSTERED started.
      21:30:46,424 INFO [ConnectionFactoryBindingService] Bound ConnectionManager 'jboss.jca:service=DataSourceBinding,name=DefaultDS' to JNDI name 'java:DefaultDS'
      21:30:47,385 INFO [A] Bound to JNDI name: queue/A
      21:30:47,387 INFO [B] Bound to JNDI name: queue/B
      21:30:47,389 INFO [C] Bound to JNDI name: queue/C
      21:30:47,391 INFO [D] Bound to JNDI name: queue/D
      21:30:47,394 INFO [ex] Bound to JNDI name: queue/ex
      21:30:47,498 INFO [testTopic] Bound to JNDI name: topic/testTopic
      21:30:47,503 INFO [securedTopic] Bound to JNDI name: topic/securedTopic
      21:30:47,508 INFO [testDurableTopic] Bound to JNDI name: topic/testDurableTopic
      21:30:47,513 INFO [testQueue] Bound to JNDI name: queue/testQueue
      21:30:47,663 INFO [UILServerILService] JBossMQ UIL service available at : /127.0.0.1:8093
      21:30:47,758 INFO [DLQ] Bound to JNDI name: queue/DLQ
      21:30:48,115 INFO [ConnectionFactoryBindingService] Bound ConnectionManager 'jboss.jca:service=ConnectionFactoryBinding,name=JmsXA' to JNDI name 'java:JmsXA'
      21:30:48,271 INFO [TomcatDeployer] deploy, ctxPath=/jmx-console, warUrl=.../deploy/jmx-console.war/
      21:30:49,076 INFO [Http11Protocol] Starting Coyote HTTP/1.1 on http-127.0.0.1-8080
      21:30:49,219 INFO [AjpProtocol] Starting Coyote AJP/1.3 on ajp-127.0.0.1-8009
      21:30:49,286 INFO [Server] JBoss (MX MicroKernel) [4.2.2.GA (build: SVNTag=JBoss_4_2_2_GA date=200710221139)] Started in 50s:272ms
      


      After that, I'm connecting on http://127.0.0.1:8080/web-console. I can see the right part of the window, but not the left part, which is a java Applet. I've the following exception :

      http://127.0.0.1:8080/web-console/Invoker
      java.lang.NoClassDefFoundError: org/jboss/logging/Logger
       at org.jboss.console.remote.Util.<clinit>(Util.java:33)
       at org.jboss.console.remote.AppletRemoteMBeanInvoker.invoke(AppletRemoteMBeanInvoker.java:64)
       at org.jboss.console.navtree.ConsoleTreeModel.loadTree(ConsoleTreeModel.java:118)
       at org.jboss.console.navtree.ConsoleTreeModel.<init>(ConsoleTreeModel.java:73)
       at org.jboss.console.navtree.AdminTreeBrowser.<init>(AdminTreeBrowser.java:77)
       at org.jboss.console.navtree.AppletBrowser.start(AppletBrowser.java:65)
       at sun.applet.AppletPanel.run(AppletPanel.java:459)
       at java.lang.Thread.run(Thread.java:619)


      I've also tried to start JBoss with a Java 6, but it's the same result.

      Some usefull information :
      OS : Fedora 7
      Firefox 2.0.0.10

      What's my problem ?

      Thanks for your help !