1 Reply Latest reply on Apr 4, 2008 2:32 AM by jaikiran pai

    Could not create deployment: file:/opt/jboss-4.0.3SP1/server

    Ram kumar Imayavaramban Newbie

      Hi Everybody,

      This is very urgent.
      Actually my requirement is deploy the application in Linux environment.
      I have installed jdk 1.5
      I have extracted Jboss 4.0.2 server.
      and I have set the environment variables like this.

      export JAVA_HOME=/opt/jdk1.5.0_15
      export PATH=$JAVA_HOME/bin:$PATH
      export JBOSS_DIST=$JBOSS_DIST:/opt/jboss-4.0.2
      my linux version is 9.0.15

      When I am trying to start the server I am getting the following exception.

      Could not create deployment: file:/opt/jboss-4.0.3SP1/server/default/conf/jboss-service.xml
      org.jboss.deployment.DeploymentException: No ClassLoaders found for: org.jboss.management.j2ee.LocalJBossServerDomain; - nested throwable: (java.lang.ClassNotFoundException: No ClassLoaders found for: org.jboss.management.j2ee.LocalJBossServerDomain)



      Please help me.I don't know where it is the problem.
      Thank you in advance..
      Thanks and Regards,
      Ram kumar.I

        • 1. Re: Could not create deployment: file:/opt/jboss-4.0.3SP1/se
          jaikiran pai Master

           

          I have extracted Jboss 4.0.2 server.


          You say you are using 4.0.2, but the error shows something about 4.0.3SP1.

          Could not create deployment: file:/opt/jboss-4.0.3SP1/server/default/conf/jboss-service.xml


          Are you sure you have downloaded the correct zip file?

          How do you start JBoss? Also, please post the entire output that you see on the console when you start JBoss.

          P.S: While posting the logs or code or xml content, remember to wrap it in a code block using the Code button in the message editor window and please hit the Preview button to make sure your post is correctly formatted