1 Reply Latest reply on Apr 17, 2008 1:16 AM by jaikiran pai

    No JNDIView MBean when installing from JEMS 1.2.1 Installer

    tnine Newbie

      Hi all,
      I'm using the jems installer verion 1.2.1.CR4 to install a stripped down version of the "all" server. Basically I'm removing a lot of services as I only need EJB, EJB3, clustering, and Messaging. However, when I view the jmx-console, the JNDIView Mbean is not present. If I accept the defaults and leave everything checked in the all configuration and install a new server, it does not appear either. I only get it when I download 4.2.2 GA distribution and run it. Is this mbean missing from the JEMS installer, or did I just miss a step during the installation?

        • 1. Re: No JNDIView MBean when installing from JEMS 1.2.1 Instal
          jaikiran pai Master

          I personally do not use the JEMS installer, mainly because the other option of just downloading and unzipping the archive is pretty easy. Moreover, i have seen many issues reported in the forums about JBoss installation using the JEMS installer.

          As far as JNDIView MBean is concerned, when you installed the server, do you see the following section in the jboss-service.xml file present in %JBOSS_HOME%/server/all/conf folder:

          <mbean code="org.jboss.naming.JNDIView"
           name="jboss:service=JNDIView"
           xmbean-dd="resource:xmdesc/JNDIView-xmbean.xml">
           <!-- The HANamingService service name -->
           <attribute name="HANamingService">jboss:service=HAJNDI</attribute>
           </mbean>