1 Reply Latest reply on May 14, 2008 12:05 PM by Hildeberto Mendonca

    JBoss deployment problem

    Lei Yanli Newbie

      Hi experts

      I am using Jboss 4.2.2.GA to deploy my java ee program but suddenly today the error msg came out when i deploy it. (Previously the program can be deployed correctly). Here is the error msg:

      --- MBeans waiting for other MBeans ---
      ObjectName: persistence.units:ear=EVSEntApp.ear,jar=EVSEntApp-ejb.jar,unitName=EVSEntApp-ejbPU
      State: NOTYETINSTALLED
      I Depend On:
      jboss.jca:name=DefaultEVS,service=DataSourceBinding

      ObjectName: persistence.units:ear=EVSEntApp.ear,jar=EVSEntApp-ejb.jar,unitName=EVSEntApp-ejbPU
      State: NOTYETINSTALLED
      I Depend On:
      jboss.jca:name=DefaultEVS,service=DataSourceBinding
      Depends On Me:
      jboss.j2ee:ear=EVSEntApp.ear,jar=EVSEntApp-ejb.jar,name=BankAccountFacade,service=EJB3
      jboss.j2ee:ear=EVSEntApp.ear,jar=EVSEntApp-ejb.jar,name=ComModuleFacade,service=EJB3
      jboss.j2ee:ear=EVSEntApp.ear,jar=EVSEntApp-ejb.jar,name=ComModuleTypeFacade,service=EJB3
      jboss.j2ee:ear=EVSEntApp.ear,jar=EVSEntApp-ejb.jar,name=MeterFacade,service=EJB3
      jboss.j2ee:ear=EVSEntApp.ear,jar=EVSEntApp-ejb.jar,name=MeterGroupFacade,service=EJB3
      jboss.j2ee:ear=EVSEntApp.ear,jar=EVSEntApp-ejb.jar,name=MeterGroupMemberFacade,service=EJB3
      jboss.j2ee:ear=EVSEntApp.ear,jar=EVSEntApp-ejb.jar,name=MeterStatusFacade,service=EJB3
      jboss.j2ee:ear=EVSEntApp.ear,jar=EVSEntApp-ejb.jar,name=MeterTypeFacade,service=EJB3
      jboss.j2ee:ear=EVSEntApp.ear,jar=EVSEntApp-ejb.jar,name=OfferDetailFacade,service=EJB3
      jboss.j2ee:ear=EVSEntApp.ear,jar=EVSEntApp-ejb.jar,name=OfferFacade,service=EJB3
      jboss.j2ee:ear=EVSEntApp.ear,jar=EVSEntApp-ejb.jar,name=PremiseFacade,service=EJB3
      jboss.j2ee:ear=EVSEntApp.ear,jar=EVSEntApp-ejb.jar,name=PremiseTypeFacade,service=EJB3
      jboss.j2ee:ear=EVSEntApp.ear,jar=EVSEntApp-ejb.jar,name=EnergyFacade,service=EJB3
      jboss.j2ee:ear=EVSEntApp.ear,jar=EVSEntApp-ejb.jar,name=AccessRightFacade,service=EJB3
      jboss.j2ee:ear=EVSEntApp.ear,jar=EVSEntApp-ejb.jar,name=AccessRightListFacade,service=EJB3
      jboss.j2ee:ear=EVSEntApp.ear,jar=EVSEntApp-ejb.jar,name=CustomerFacade,service=EJB3
      jboss.j2ee:ear=EVSEntApp.ear,jar=EVSEntApp-ejb.jar,name=OperatorFacade,service=EJB3
      jboss.j2ee:ear=EVSEntApp.ear,jar=EVSEntApp-ejb.jar,name=PageParaFacade,service=EJB3
      jboss.j2ee:ear=EVSEntApp.ear,jar=EVSEntApp-ejb.jar,name=PageParaListFacade,service=EJB3
      jboss.j2ee:ear=EVSEntApp.ear,jar=EVSEntApp-ejb.jar,name=RetailerFacade,service=EJB3
      jboss.j2ee:ear=EVSEntApp.ear,jar=EVSEntApp-ejb.jar,name=UserAccountFacade,service=EJB3
      jboss.j2ee:ear=EVSEntApp.ear,jar=EVSEntApp-ejb.jar,name=WorkgroupFacade,service=EJB3

      ObjectName: jboss.j2ee:ear=EVSEntApp.ear,jar=EVSEntApp-ejb.jar,name=BankAccountFacade,service=EJB3
      State: NOTYETINSTALLED
      I Depend On:
      persistence.units:ear=EVSEntApp.ear,jar=EVSEntApp-ejb.jar,unitName=EVSEntApp-ejbPU

      ObjectName: jboss.j2ee:ear=EVSEntApp.ear,jar=EVSEntApp-ejb.jar,name=ComModuleFacade,service=EJB3
      State: NOTYETINSTALLED
      I Depend On:
      persistence.units:ear=EVSEntApp.ear,jar=EVSEntApp-ejb.jar,unitName=EVSEntApp-ejbPU

      -----------------
      the error msg saying I did not install DataSourceBinding...but previously the whole deployment was ok and the system was running also.
      -----------------

      Here is my hsqldb-ds.xml portion:
      <!-- Oracle -->
      <local-tx-datasource>
      <jndi-name>DefaultEVS</jndi-name>
      <connection-url>jdbc:oracle:thin:@127.0.0.1:1521:evs</connection-url>
      <driver-class>oracle.jdbc.driver.OracleDriver</driver-class>
      <user-name>evs</user-name>
      evs
      <min-pool-size>5</min-pool-size>
      <max-pool-size>20</max-pool-size>
      <idle-timeout-minutes>0</idle-timeout-minutes>
      <track-statements/>
      <prepared-statement-cache-size>32</prepared-statement-cache-size>

      <type-mapping>Oracle10gXEr2</type-mapping>

      </local-tx-datasource>
      <!-- end of Oracle -->

      Before this error came out, I did changes for the connection-url, changed the IP 127.0.0.1 to other IP as I wanted to connect to a database sitting on other PC, and after It was working well after I did the change. But when I continue my programming work for a while this msg out when i deploy... really headache...

      Any idea of it??
      Tks alot for ur kindest help.