2 Replies Latest reply on Jun 27, 2008 12:26 AM by Vivek MK

    Sub Folder is not supporting .xhtml(seam)

    Vivek MK Newbie

      Hi all,
      We implemented a demo using jboss seams and working properly. For
      implementing security i want to move some .xhtml file into a new directory called "wizard". but if i am trying to access the .xhtml file in to that directory i am getting an error as

      HTTP Status 404 - /DemoChaptor6/wizard/loggedInUser.seam

      I know it is a configuration error, but i don't know how to configure it.

      Can any one help me pleas.

      Regards vivek.

        • 1. Re: Sub Folder is not supporting .xhtml(seam)
          Peter Johnson Master

          Yes it must be a configuration error because it works fine for me. Please post your web.xml file. Make sure you bracket the XML text in [ code ] brackets (select the text and clcik the Code button).

          • 2. Re: Sub Folder is not supporting .xhtml(seam)
            Vivek MK Newbie

            Hi Peter Johnson ,

            Thanks for your replay first.I didnt understand what you are saying.Bellow is my we.xml. Can you please help me again?

            <?xml version="1.0" ?>
            <web-app xmlns="http://java.sun.com/xml/ns/javaee"
            xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
            xsi:schemaLocation="http://java.sun.com/xml/ns/javaee http://java.sun.com/xml/ns/javaee/web-app_2_5.xsd"
            version="2.5">

            <!-- Ajax4jsf -->

            <context-param>
            <param-name>org.richfaces.SKIN</param-name>
            <param-value>blueSky</param-value>
            </context-param>

            <!-- Seam -->


            <listener-class>org.jboss.seam.servlet.SeamListener</listener-class>



            <filter-name>Seam Filter</filter-name>
            <filter-class>org.jboss.seam.servlet.SeamFilter</filter-class>


            <filter-mapping>
            <filter-name>Seam Filter</filter-name>
            <url-pattern>/*</url-pattern>
            </filter-mapping>


            <servlet-name>Seam Resource Servlet</servlet-name>
            <servlet-class>org.jboss.seam.servlet.SeamResourceServlet</servlet-class>


            <servlet-mapping>
            <servlet-name>Seam Resource Servlet</servlet-name>
            <url-pattern>/seam/resource/*</url-pattern>
            </servlet-mapping>

            <!-- Facelets development mode (disable in production) -->

            <context-param>
            <param-name>facelets.DEVELOPMENT</param-name>
            <param-value>true</param-value>
            </context-param>

            <!-- JSF -->

            <context-param>
            <param-name>javax.faces.DEFAULT_SUFFIX</param-name>
            <param-value>.xhtml</param-value>
            </context-param>


            <servlet-name>Faces Servlet</servlet-name>
            <servlet-class>javax.faces.webapp.FacesServlet</servlet-class>
            <load-on-startup>1</load-on-startup>


            <servlet-mapping>
            <servlet-name>Faces Servlet</servlet-name>
            <url-pattern>*.seam</url-pattern>
            </servlet-mapping>

            <security-constraint>
            <display-name>Restrict raw XHTML Documents</display-name>
            <web-resource-collection>
            <web-resource-name>XHTML</web-resource-name>
            <url-pattern>*.xhtml</url-pattern>
            </web-resource-collection>
            <auth-constraint/>
            </security-constraint>



            </web-app>