0 Replies Latest reply on Jul 17, 2008 9:11 AM by yxyx yxyx

    Client library compatibility issues 4.2.0.GA -> 4.2.2.GA

    yxyx yxyx Newbie

      According to http://wiki.jboss.org/wiki/JBossVersionCompatibilityMatrix a 4.2.0 client should be able to invoke ejb3 application running on JBoss AS 4.2.2.
      This doesn't work for me, I get:
      java.io.InvalidClassException: org.jboss.ejb3.remoting.BaseRemoteProxy; local class incompatible: stream classdesc serialVersionUID = -2711693270411201590, local class serialVersionUID = 1126421850898582900

      Client is using the jbossall-client.jar from JBoss 4.2.0.GA. The application is build using the libraries from JBoss 4.2.0.GA. When running on a JBoss AS 4.2.0 everything is ok. But if I deploy the application on a JBoss 4.2.2 and run the client against it, i got the InvalidClassException.
      I can get the client running only if I use the jbossall-client.jar from JBoss 4.2.2.