2 Replies Latest reply on Jul 29, 2008 11:36 AM by Ken Van Camp

    Incomplete Deployment listing when upgrading from JBoss AS 4

    Ken Van Camp Newbie

      I have an existing application working with JBoss 4.0.2 (running under JDK 1.4.2). I am trying to upgrade to JBoss 4.2.2 and JDK 1.5, and am getting the error "Incomplete Deployment listing" on my deployment package. I've searched the release notes and FAQ, and can't find any reference to known changes for this issue.

      The andesa-itm-war being mentioned in the following logged output is a folder containing a WEB-INF folder, which has a web.xml and jboss-web.xml.

      Here is the output I'm seeing:

      13:36:48,771 INFO [EARDeployer] Init J2EE application: file:/C:/jboss-4.2.2.GA/server/default/deploy/andesa-itm.ear/
      13:36:51,099 INFO [EARDeployer] Started J2EE application: file:/C:/jboss-4.2.2.GA/server/default/deploy/andesa-itm.ear/
      13:36:51,099 ERROR [URLDeploymentScanner] Incomplete Deployment listing:

      --- Packages waiting for a deployer ---
      org.jboss.deployment.DeploymentInfo@63fc729a { url=file:/C:/jboss-4.2.2.GA/server/default/deploy/andesa-itm.ear/andesa-itm-war/ }
      deployer: null
      status: Starting
      state: START_SUBDEPLOYMENTS
      watch: file:/C:/jboss-4.2.2.GA/server/default/deploy/andesa-itm.ear/andesa-itm-war/
      altDD: null
      lastDeployed: 1217266611084
      lastModified: 1217266565630
      mbeans:

      13:36:51,318 INFO [Http11Protocol] Starting Coyote HTTP/1.1 on http-127.0.0.1-8080

      Ken Van Camp