2 Replies Latest reply on Dec 19, 2008 6:40 PM by Chris Carr

    JBoss 4.2.3 and Maven

    Martin Höller Newbie

      Hi all!

      Does anybody know the supposed way of building an EAR project including remote clients with maven for JBoss AS 4.2.3?

      Currently we are building a project (an EAR with some remote clients) with Maven 2 which is going to run in/connect to JBoss AS. So far we were using JBoss 4.2.2 with no problems. In our project we use various JBoss JARs (dependencies in maven terms) like jboss-ejb3-client.jar, jbossall-client.jar, jboss-ejb-api.jar which we got from JBoss' maven repository http://repository.jboss.com/maven2/.

      Now, that JBoss 4.2.3 is out, we want to upgrade to this version but get java.io.InvalidClassExceptions (at least) for the class org.jboss.ejb3.remoting.BaseRemoteProxy.

      The Problem seems to be that jboss-ejb3-client.jar which comes with JBoss 4.2.3 is compiled with a different java version than the one which is found in the maven repository, so our application has a different class than the JBoss instance with which it is going to communicate. The same problem is very likely to hit other JARs as well, this is just the first error we get.

      Any hints anyone?

      tia,
      - martin