2 Replies Latest reply on Aug 6, 2008 5:19 AM by jaikiran pai

    Problem with JAXB when upgrading to JBoss 4.2.2

    Steve Singer Newbie

      I'm having a problem and I am ripping my hair out trying to resolve!

      We have an application that uses JSXB to marshall XML objects. We're using "jaxb-rt-1.0-ea.jar" and we include the JAR file in the application and in the CLASSPATH. Works perfectly in 4.0.4.

      I'm trying to get the application up in 4.2.2GA, and I get the following error:

      java.lang.NoSuchFieldError: INITIAL_COLOR
      javax.xml.bind.ValidatableObject.(ValidatableObject.java:32)
      javax.xml.bind.MarshallableObject.(MarshallableObject.java:54)
      javax.xml.bind.MarshallableRootElement.(MarshallableRootElement.java:97)

      This type of thing almost always happens when there is a mismatch between the classes it is compiled against as opposed to run against. However, I checked, and these classes exist only in "jaxb-rt-1.0-ea.jar" and nowhere else within JBoss. "jaxb-rt-1.0-ea.jar" is still inthe application, and in the CLASSPATH.

      Anybody have any idea what might be happening? Hopefully, it's just something dumb I'm doing.