8 Replies Latest reply on Oct 30, 2009 4:17 AM by Peter Schilling

    EAR validation?

    jsingh jsingh Newbie

      Is there a tool that does EAR format validations? Things like if all the descriptors are present as hosuld be etc?
      Basically trying to deploy an EAR from JRun to JBoss and get the following messages for a lot of XML, JSP and other property files:
      Package waiting for deployer.

      In some other post I had read that this might happen if the EAR is named as deploy.ear, but that is not the case in my scenario.
      Thanks.

        • 1. Re: EAR validation?
          Peter Johnson Master

          It is impossible to debug any issue on a partial error message excerpt. Please post the full, first exception stack trace.

          The "package waiting for deployer" means that there is no deployer for that type of package. What package? I have no idea, you did not include that in your post (the full stack trace will include that info).

          • 2. Re: EAR validation?
            jsingh jsingh Newbie

            Ok. I am pasting the log I get per file. I get the same message for a bunch of other files:

            2008-08-06 17:30:44,415 DEBUG [org.jboss.deployment.MainDeployer] Deployment of package: file:/C:/software/jboss-4.2.2.GA/server/default/deploy/app1/app1-war/index.jsp is waiting for an appropriate deployer.
            2008-08-06 17:30:44,415 DEBUG [org.jboss.deployment.scanner.URLDeploymentScanner] Watch URL for: file:/C:/software/jboss-4.2.2.GA/server/default/deploy/app1/app1-war/index.jsp -> file:/C:/software/jboss-4.2.2.GA/server/default/deploy/app1/app1-war/index.jsp
            2008-08-06 17:30:44,415 ERROR [org.jboss.deployment.scanner.URLDeploymentScanner] Incomplete Deployment listing:

            --- Packages waiting for a deployer ---
            org.jboss.deployment.DeploymentInfo@9bf0d9a1 { url=file:/C:/software/jboss-4.2.2.GA/server/default/deploy/app1/META-INF/application.xml }
            deployer: null
            status: null
            state: INIT_WAITING_DEPLOYER
            watch: file:/C:/software/jboss-4.2.2.GA/server/default/deploy/app1/META-INF/application.xml
            altDD: null
            lastDeployed: 1218058244040
            lastModified: 1218058244040
            mbeans:

            Similar messages for multiple files ending with:

            org.jboss.deployment.DeploymentInfo@271dfd65 { url=file:/C:/software/jboss-4.2.2.GA/server/default/deploy/app1/app1-war/index.jsp }
            deployer: null
            status: null
            state: INIT_WAITING_DEPLOYER
            watch: file:/C:/software/jboss-4.2.2.GA/server/default/deploy/app1/app1-war/index.jsp
            altDD: null
            lastDeployed: 1218058244415
            lastModified: 1218058244383
            mbeans:

            • 3. Re: EAR validation?
              jaikiran pai Master

               

              file:/C:/software/jboss-4.2.2.GA/server/default/deploy/app1


              Rename app1 to app1.ear



              • 4. Re: EAR validation?
                jsingh jsingh Newbie

                thanks, that worked to a degree, but I am getting another exception now (see below). I have not 'jarred' these files since I thinkthat exploded directories should work in JBoss(?), so the .ear, .war, .ejb are folders:

                I think the problem might be in line 3 from below, as usually WAR URL should point to the tmp directory eg: ' warUrl=.../tmp/deploy/tmp20973example3.ear-contents/example3-exp.war/'

                But I don't know what the cause is.


                16:53:57,210 INFO [TomcatDeployer] deploy, ctxPath=/jmx-console, warUrl=.../deploy/jmx-console.war/
                16:53:57,585 INFO [EARDeployer] Init J2EE application: file:/C:/software/jboss-4.2.2.GA/server/default/deploy/app1.ear/
                16:53:57,851 INFO [TomcatDeployer] deploy, ctxPath=/, warUrl=.../deploy/app1.ear/app1.war/
                16:53:57,976 ERROR [Digester] End event threw exception
                java.lang.reflect.InvocationTargetException
                at sun.reflect.GeneratedMethodAccessor49.invoke(Unknown Source)
                at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
                at java.lang.reflect.Method.invoke(Method.java:585)
                at org.apache.tomcat.util.IntrospectionUtils.callMethodN(IntrospectionUtils.java:932)
                at org.apache.catalina.startup.CallMethodMultiRule.end(WebRuleSet.java:792)
                at org.apache.tomcat.util.digester.Rule.end(Rule.java:229)
                at org.apache.tomcat.util.digester.Digester.endElement(Digester.java:1136)
                at org.apache.xerces.parsers.AbstractSAXParser.endElement(Unknown Source)
                at org.apache.xerces.impl.dtd.XMLDTDValidator.endNamespaceScope(Unknown Source)
                at org.apache.xerces.impl.dtd.XMLDTDValidator.handleEndElement(Unknown Source)
                at org.apache.xerces.impl.dtd.XMLDTDValidator.endElement(Unknown Source)
                at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanEndElement(Unknown Source)
                at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl$FragmentContentDispatcher.dispatch(Unknown Source)
                at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown Source)
                at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
                at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
                at org.apache.xerces.parsers.XMLParser.parse(Unknown Source)
                at org.apache.xerces.parsers.AbstractSAXParser.parse(Unknown Source)
                at org.apache.xerces.jaxp.SAXParserImpl$JAXPSAXParser.parse(Unknown Source)
                at org.apache.tomcat.util.digester.Digester.parse(Digester.java:1643)
                at org.apache.catalina.startup.ContextConfig.applicationWebConfig(ContextConfig.java:369)
                at org.apache.catalina.startup.ContextConfig.start(ContextConfig.java:1062)
                at org.apache.catalina.startup.ContextConfig.lifecycleEvent(ContextConfig.java:261)
                at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:117)
                at org.apache.catalina.core.StandardContext.start(StandardContext.java:4263)
                at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:790)

                • 5. Re: EAR validation?
                  jsingh jsingh Newbie

                  oh, or maybe the 'tmp' directory is only used when the ear/war are unexploded. sorry for misguiding but the problem remains for me.

                  • 6. Re: EAR validation?
                    Peter Johnson Master

                    Based on this:

                    16:53:57,851 INFO [TomcatDeployer] deploy, ctxPath=/, warUrl=.../deploy/app1.ear/app1.war/

                    it appears that app1 is using the default context. Have you removed ROOT.war? It also uses the default context.

                    • 7. Re: EAR validation?
                      jsingh jsingh Newbie

                      I tried by removing Root.war. Still get the same error. I also tried adding / removing <context-root> tags from application.xml and jboss-web.xml. Get the same exception. Am I missing defining the root context somewhere? btw I would want to keep it default.

                      • 8. Re: EAR validation?
                        Peter Schilling Newbie

                        Did you solve this? I have the same problem. Thanks