6 Replies Latest reply on Sep 23, 2008 6:56 AM by ramakanta sahoo

    Need suggestion about how to proceed.

    ramakanta sahoo Newbie

      Hi all,

      I'm migrating from websphere to JBoss 4.2.3GA.
      So i need help in deploying and configuring app in JBoss.
      JBoss server is deployed and running perfectly fine.

      What i do in Websphere.
      1.I deploy the WAR file which contains only jar files.
      2.I give Java Virtual Machine arguments in each server.
      JVM Args: -DMSM.HOME=/opt/MSM/SYSTEMi/Systemi -DMSM.CONFIG=/opt/MSM/Sys/Config/config.xml
      3.I copy the resource folder to some location like opt/MSM/SYSTEMi/Systemi/Resource this folder contains all the html files and templates used for IBM HTTP Server.
      4.Once i finished configuring httpd.conf file in HTTP server, i restart the App server and thats all deployment finished

      Note: Config.xml contains all the configuration parameters for MSMApp
      like hostname,webservice port number,jdbc details,etc.
      We use our connection pool to connect to oracle db.

      For Jboss what i did till now:

      1.Installed JBoss in /opt/JBoss folder successfully. already set all the env varibales like JAVA_HOME,JBOSS_HOME,etc.
      2.Copied WAR file to default/deploy folder
      3.created Resouce folder where all HTML and templates resides.
      4.In run.sh file exported one parameter JAVA_OPTS
      I have set JAVA_OPTS variable with all the java arguments i gave in Websphere.
      which is -DMSM.HOME=/opt/MSM/SYSTEMi/Systemi -DMSM.CONFIG=/opt/MSM/Sys/Config/config.xml
      5.Restarted the server as parameter run.sh -c default -b 0.0.0.0
      6.Server restarted successfully with out any errors.
      7.In Jboss console Application list my application is showing up active and deployed.
      8.But still I'm not able to view my application.
      9.My application Url: http://localhost:8080/MSM/Userlogin
      10.So after all these Please suggest me am i missing something which is required for configuration.
      (This much configuration works fine in Websphere.}

        • 1. Re: Need suggestion about how to proceed.
          ramakanta sahoo Newbie

           

          "rks_86" wrote:
          Hi all,

          I'm migrating from websphere to JBoss 4.2.3GA.
          So i need help in deploying and configuring app in JBoss.
          JBoss server is deployed and running perfectly fine.

          What i do in Websphere.
          1.I deploy the WAR file which contains only jar files.
          2.I give Java Virtual Machine arguments in each server.
          JVM Args: -DMSM.HOME=/opt/MSM/SYSTEMi/Systemi -DMSM.CONFIG=/opt/MSM/Sys/Config/config.xml
          3.I copy the resource folder to some location like opt/MSM/SYSTEMi/Systemi/Resource this folder contains all the html files and templates used for IBM HTTP Server.
          4.Once i finished configuring httpd.conf file in HTTP server, i restart the App server and thats all deployment finished

          Note: Config.xml contains all the configuration parameters for MSMApp
          like hostname,webservice port number,jdbc details,etc.
          We use our connection pool to connect to oracle db.

          For Jboss what i did till now:

          1.Installed JBoss in /opt/JBoss folder successfully. already set all the env varibales like JAVA_HOME,JBOSS_HOME,etc.
          2.Copied WAR file to default/deploy folder
          3.created Resouce folder where all HTML and templates resides.
          4.In run.sh file exported one parameter JAVA_OPTS
          I have set JAVA_OPTS variable with all the java arguments i gave in Websphere.
          which is -DMSM.HOME=/opt/MSM/SYSTEMi/Systemi -DMSM.CONFIG=/opt/MSM/Sys/Config/config.xml
          5.Restarted the server as parameter run.sh -c default -b 0.0.0.0
          6.Server restarted successfully with out any errors.
          7.In Jboss console Application list my application is showing up active and deployed.
          8.But still I'm not able to view my application.
          9.My application Url: http://localhost:8080/MSM/Userlogin
          10.So after all these Please suggest me am i missing something which is required for configuration.
          (This much configuration works fine in Websphere.}
          AM deploying in Ent. Linux 4


          • 2. Re: Need suggestion about how to proceed.
            jaikiran pai Master

            What is the name of the WAR file that you place in the deploy folder? Also post the JBoss console logs.

            While posting the logs or xml content or code, remember to wrap it in a code block using the Code button in the message editor window and please hit the Preview button to make sure your post is correctly formatted

            • 3. Re: Need suggestion about how to proceed.
              ramakanta sahoo Newbie

               

              "jaikiran" wrote:
              What is the name of the WAR file that you place in the deploy folder? Also post the JBoss console logs.

              While posting the logs or xml content or code, remember to wrap it in a code block using the Code button in the message editor window and please hit the Preview button to make sure your post is correctly formatted


              Thanks

              After you told me to send the server log files i just grepped through the log and found that my applications key files are curropt thats why its not taking my config.xml file.
              I found no errors except the above license key invalid.

              Noe I'm able to login to the application but the html & javascript files files are not showing up .So the gui looks horrible. I think its not able to take the Resource folder which contains all the GUI stuff.
              Do i need to set some variable in some httpd.conf file to let my Resource folder recognized by server.
              like in apache we set Custom_Template_Root "blash/blah/"
              Alias, etc etc.
              If these all required then please let me know where should i set these parameters .

              Thanks,
              Rk

              • 4. Re: Need suggestion about how to proceed.
                Peter Johnson Master

                There is no such thing as a "Resource folder" in JBossAS. But perhaps this will help: http://wiki.jboss.org/wiki/ExternalDirectories

                Also, regarding the MSM.HOME and MSM.CONFIG system properties - are these properties that your code uses? JBossAS will ignore them.

                • 5. Re: Need suggestion about how to proceed.
                  ramakanta sahoo Newbie

                  No, I dont think JBoss ignoring those MSM.HOME and MSM.CONFIG properties. As I'm able to login to my application it seems that its taking the DB details from my application property file config.xml(Am not sure)
                  as its showing up in the login page the username and password field and I'm able to login into my application whose all data are inside a oracle schema. But its not able to take the css files present may be thats why GUI looks odd.
                  And the Resource folder is not from JBoss its my applications Resouce folder which contains all css and templates for my application.

                  I have made my app work in windows system long time back with JBoss4.0.5 but there i made big changes in Jboss config files to make it work which i dont want for linux system.

                  I need to figureit out how JBoss will cache my css and templates.
                  Yours suggestions are worthful. Thanks a lot.
                  I think I will make it work very soon.
                  and will post the results how i made it work .please keep this thread in watch list.

                  Thanks a lot.

                  • 6. Re: Need suggestion about how to proceed.
                    ramakanta sahoo Newbie

                    Hi Peter,

                    I made it work.
                    Now all static contents are processed by Apache 2.2.9 with the help of mod-jk.properties.
                    So now all working fine...
                    I have kept JAVA_OPTS as it is!!
                    Appserver loads the jar file provided inside MS.war file and all the static contents are provided by apache.

                    Thanks,
                    Ramakant