1 Reply Latest reply on Nov 2, 2008 2:43 AM by jaikiran pai

    org.jboss.deployment.DeploymentException: No META-INF/applic

    nicolas duminil Novice

      Greetings,

      This issue apears time to time, during EAR deployments, since the 3.0 version. I thought JBoss people have gotten rid of it but no, I'm keeping experimenting it with 4.2.5 and I won't be surprized to find it in the 5.0 version, if I'll be ever enough kami-kaze to dare using it.

      The issue has been signaled dozens of times but lots of people. Sometimes it happens while using certains versions of WinZip or WinRAR, because JBoss AS doesn't seem to be able to find folders inside. As far as I'm concerned, I'm not using neither WinZip nore WinRAR, but it happens anyway, approximativelly 3 times on 10 deployments, without any apparent reason.

      It's good to see that the sum of the bugs in JBoss AS is constant and that, times they are achangin', as Bob Dylan used to say, but not JBoss bugs.

      Kind regards,

      Nicolas

        • 1. Re: org.jboss.deployment.DeploymentException: No META-INF/ap
          jaikiran pai Master

          I have seen people complaining about this exception and it turning out to be a issue with how the application was packaged. So far i haven't seen a post where this turned out to be an issue with the way JBoss deploys the application.

          If you think, it might be related to JBoss than the packaging, please post more details including the exception stacktrace, the output of:

          jar -tf yourapp.ear


          and the version of Java you are using and also the tool or script which you use for creating the ear.

          And does this happen when you are redeploying (hot-deploying) the application?