1 Reply Latest reply on Nov 18, 2008 4:49 PM by James McPhail

    ear deployment from 4.0.3SP1 doesn't work on 4.2.2.GA

    James McPhail Newbie

      I have an ear working on v4.0.3SP1 (linux) which I am migrating to v4.2.2.GA (linux).

      When I deploy the .ear file to v4.2.2.GA, while trying to deploy a .war contained within the .ear the deployer will throw a ClassDefNotFoundError exception. In an attempt to get this ear working I got around several ClassDefNotFoundErrors by copying some .class files from the .war into a .jar file which is also contained in the .ear.

      Following this, I now I get

      org.jboss.ws.WSException: Cannot obtain method parameter mapping for message part 'licenseKey' in wsdl operation

      as jboss is trying to deploy the .war of the package. At this point I am unsure how to overcome this problem.

      Any suggestions on what might be going wrong (with either problem)? Thanks in advance!