2 Replies Latest reply on Dec 29, 2008 11:04 AM by biebel1975

    JBoss 5.0.0. G.A. with JDK6 won't start

    biebel1975 Newbie

      Hi,

      I try to start JBoss 5.0.0 GA on a windows 2008 web server (x64).

      This is the only thing which appears in the console:

      ===============================================================================

      JBoss Bootstrap Environment

      JBOSS_HOME: D:\jboss-5.0.0.GA

      JAVA: D:\jdk1.6.0_11\bin\java

      JAVA_OPTS: -Dprogram.name=run.bat -server -Xms128m -Xmx2048m -XX:MaxPermSize=1024m -Dorg.jboss.resolver.warning=true -Dsun.rmi.dgc.client.gcInterval=3600000 -Dsun.rmi.dgc.server.gcInterval=3600000 -Xdebug -Xrun
      jdwp:transport=dt_socket,address=8787,server=y,suspend=y

      CLASSPATH: D:\jboss-5.0.0.GA\bin\run.jar

      ===============================================================================

      Listening for transport dt_socket at address: 8787

      It seems that JBoss isn't started at all.
      Has anyone encountered the same problem or knows the solution.

      Thanks

        • 1. Re: JBoss 5.0.0. G.A. with JDK6 won't start
          jaikiran pai Master

           

          JAVA_OPTS: -Dprogram.name=run.bat -server -Xms128m -Xmx2048m -XX:MaxPermSize=1024m -Dorg.jboss.resolver.warning=true -Dsun.rmi.dgc.client.gcInterval=3600000 -Dsun.rmi.dgc.server.gcInterval=3600000 -Xdebug -Xrun
          jdwp:transport=dt_socket,address=8787,server=y,suspend=y


          You have enabled JBoss to run in debug mode and set the suspend=y. So unless you connect a debugger (like Eclipse IDE), the server will be in suspended state.

          You have 2 options:

          1) Disable debugging - You can do this in the run.bat file by commenting out the JAVA_OPTS section where the debugging options are set

          or

          2) Set the suspend=n in the JAVA_OPTS. This way, the server will start without waiting for the debugger to attach itself.


          • 2. Re: JBoss 5.0.0. G.A. with JDK6 won't start
            biebel1975 Newbie

            Thanks, it works. Stupid of me.