1 Reply Latest reply on Mar 17, 2009 3:54 PM by Craig McDaniel

    Clustering Problem

    Craig McDaniel Newbie

      I'm having trouble getting clustering to work for me.

      I've got two machines in the same workgroup. I've tried starting the application server on each machine with the following commands:

      run -c all
      run -c all -g Demo
      run -c all -g Demo -b [ip address of the machine]

      On each, I've got a very simple stateless session bean deployed (just to send a message to console so that I can see it's executing).

      With the first two run commands, the server starts, but does not recognize the other machine as part of the cluster or group. The following messages appear on both servers (with different port numbers)

      [GroupMember] I am (127.0.0.1:1568)
      [GroupMember] New Members : 1 ([127.0.0.1:1568])
      [GroupMember] All Members : 1 ([127.0.0.1:1568])

      I can run a test client using localhost:1099 in the JNDI properties and it will find and execute the bean on the local server but doesn't find the other server. If I put the ip address of either machine in place of localhost, I get a CommunicationException.

      The third run command gives Communication exceptions on startup of most of the services.

      When I ran the McastSenderTest & McastReceiverTest programs, I was able to send/receive messages between the two machines (both directions).


      So after all of that, here's the question: Could someone point me to a tutorial or troubleshooting guide that might help me get past this problem?

      Thanks,
      Craig