3 Replies Latest reply on May 20, 2009 11:57 AM by Peter Johnson

    An error occurred while processing your request. Please try

    Mark Spoon Newbie

      Hello to all,

      i deployed a *ear file from an webapplication on the JBOSS 4.0.5 and can also run the JBOSS and log in into the webside.

      All ok so far.

      All applets inside of the Internet explorer browser webpage are running only one doesnt work.

      It gives me the error: "An error occurred while processing your request. Please try again."

      Can you tell me how can i fix the problem.

      Thanks.


        • 1. Re: An error occurred while processing your request. Please
          Peter Johnson Master

          Without know what the application does, it is impossible to say how to fix it. Who did you get the app from? Does the app vendor offer support? Do you have the source code for the app? Are you sure that it is a an applet that is having the problem? Do you know what the applet is doing or attempting to do? Have you opened the Java control panel within the browser - that usually can tell you if the Java code got an exception.

          • 2. Re: An error occurred while processing your request. Please
            Mark Spoon Newbie

            i got this error out of a log file:

            My config. Windows Server 2003 on SQL 2005 Database, and JBOSS 4.0.5GA.

            PhoenixException: DBEngine.executeSelect: {SELECT count(*) thecount FROM {oj task LEFT OUTER JOIN rsrc ON task.rsrc_id=rsrc.rsrc_id} WHERE ( task.task_type = 'TT_Mile' OR task.task_type = 'TT_FinMile') AND task.proj_id = 1017 AND ( (task.status_code = 'TK_NotStart' AND task.target_end_date < '2009-05-07 14:46:20') OR (task.status_code = 'TK_Complete' AND task.act_end_date > '2009-04-17 14:46:20' AND task.act_start_date < '2009-05-07 14:46:20') )}
            Bei der Konvertierung eines char-Datentyps in einen datetime-Datentyp liegt der datetime-Wert außerhalb des gültigen Bereichs.

            • 3. Re: An error occurred while processing your request. Please
              Peter Johnson Master

              Looks like the database doesn't like like the SQL, or the app server cannot properly convert a field (looks like char vs datetime mismatch).

              Are you using container-managed persistence (CMP) or bean-managed persistence(BMP)? If CMP, post your *-ds.xml file. If BMP, check the mappings in the code.

              When posting XML text or source code, please enclose the text in UBBCode "code" tags - you can do this by selecting the text and clicking the Code button above the editor window. Also, click the Preview button to ensure that the formatting is correct and the XML text shows up before posting.