0 Replies Latest reply on May 21, 2009 8:42 AM by Lakshmi Rajagopal

    How to get JBOSS to use parsers in web-inf/lib

    Lakshmi Rajagopal Newbie

      <Newbie to JBoss>

      I have installed JBOSS EAP 4.3 GA CP04 ( JDK 1.5 )

      I have dom4j-1.6.1.jar xercesImpl-2.9.1.jar xml-apis-1.3.04.jar in my WEB-INF/lib . These are used for some application specific functionality. I need JBOSS to use this version of jars overriding its own version.

      I added this piece in the jboss-web.xml and deployed my war file.
      <loader-repository>
      com.arisglobal:loader=agx63.war
      <loader-repository-config>
      java2ParentDelegation=false
      </loader-repository-config>
      </loader-repository>

      Inspite of this, I am unable to force JBOSS to use my version of the jars.

      I also tried to add to JBOSS_CLASSPATH in the run.bat. BUt this requires to comment the JBOSS endorsed Libraries. THis is causing un-expected behaviour. The same war file I deployed once, is not getting deployed the second time.

      Please suggest if I have not approached this problem the right way.