2 Replies Latest reply on Jun 3, 2009 3:24 AM by raj reddy

    document save problem with apache 2.2 and JBoss 4.3

    raj reddy Newbie

      Hi,
      Currently our application is in production on WebLogic 9.2 with Apache 2.2 as web server and we need the same application to host on JBoss 4.3 EAP.
      Through our application we can edit .doc files, which is made possible with the use of Jacob.dll and MS ActivX at client. We have given virtual-directory-mapping in weblogic.xml where the location of .doc path is configured.

      We have installed JBoss in ‘D:/jboss430’ and apache 2.2.11 in C:\Program Files\Apache Software Foundation\Apache2.2.

      We have deployed application on JBoss 4.3 using Apache HTTP Server 2.2.11 successfully. We are facing one problem with respect to edit of document.

      We are able to open the document(.doc files) for editing, but after modifying the document, when we try to save the document using the save option in MS-Word, the copy of the same document is saved in Apache server folder instead of updating the document from the location from where it was opened. When we try to save the modified document into database, since application specific folder is not updated with user modified content, modified document is not getting saved into database.

      The httpd.conf file has the following content added/modified:

      Removed the comments for the following modules:

      1. LoadModule dav_module modules/mod_dav.so
      2. LoadModule dav_fs_module modules/mod_dav_fs.so

      Added the below lines at the bottom of httpd.conf

      Include conf/mod_jk22.conf
      DavLockDB /DavLock
      <Location /agComposer/templates>
      Dav On
      <Limit PROPFIND PUT POST DELETE PROPPATCH MKCOL COPY MOVE LOCK UNLOCK>
      Allow from localhost


      Alias /agComposer/ "D:/jboss430/jboss-as/server/production/deploy/agComposer/"
      <Directory "D:/jboss430/jboss-as/server/ production /deploy/agComposer/">
      Options Indexes MultiViews
      AllowOverride None
      Order allow,deny
      Allow from all


      The mod_jk22.conf contains the following contents:
      LoadModule jk_module modules/mod_jk22.so
      JkWorkersFile conf/workers.properties
      JkMount /* node1
      JkLogFile logs/mod_jk.log
      # Set the jk log level [debug/error/info]
      JkLogLevel info
      # Select the log format
      JkLogStampFormat "[%a %b %d %H:%M:%S %Y]"

      The workers.properties contains the following contents:
      worker.list = node1
      worker.node1.host = 127.0.0.1
      worker.node1.port = 8009
      worker.node1.type=ajp13

      In server.xml we have given the following element:


      When we click on some link in application for editing, the application places the .doc file in ‘D:/jboss430/jboss-as/server/production/deploy/agComposer/templates’ folder and apache picks up the file for editing. After we modify the content and click on save the document is getting saved on ‘C:\Program Files\Apache Software Foundation\Apache2.2’ folder instead of updating in ‘D:/jboss430/jboss-as/server/production/deploy/agComposer/templates’.

      Please suggest us the alternate approach or provide us any configuration changes to achieve the same.



        • 1. Re: document save problem with apache 2.2 and JBoss 4.3
          raj reddy Newbie

          Hi,
          Currently our application is in production on WebLogic 9.2 with Apache 2.2 as web server and we need the same application to host on JBoss 4.3 EAP.

          Through our application we can edit .doc files, which is made possible with the use of Jacob.dll and MS ActivX at client. We have given virtual-directory-mapping in weblogic.xml where the location of .doc path is configured.

          We have installed JBoss in “D:/jboss430� and apache 2.2.11 in “C:\Program Files\Apache Software Foundation\Apache2.2�.
          We have deployed application on JBoss 4.3 using Apache HTTP Server 2.2.11 successfully. We are facing one problem with respect to edit of document.

          We are able to open the document(.doc files) for editing, but after modifying the document, when we try to save the document using the save option in MS-Word, the copy of the same document is saved in Apache server folder instead of updating the document from the location from where it was opened. When we try to save the modified document into database, since application specific folder is not updated with user modified content, modified document is not getting saved into database.

          The httpd.conf file has the following content added/modified:

          Removed the comments for the following modules:
          1. LoadModule dav_module modules/mod_dav.so
          2. LoadModule dav_fs_module modules/mod_dav_fs.so
          Added the below lines at the bottom of httpd.conf

          Include conf/mod_jk22.conf

          DavLockDB /DavLock
          <Location /agComposer/templates>
          Dav On
          <Limit PROPFIND PUT POST DELETE PROPPATCH MKCOL COPY MOVE LOCK UNLOCK>
          Allow from localhost


          Alias /agComposer/ "D:/jboss430/jboss-as/server/production/deploy/agComposer/"
          <Directory "D:/jboss430/jboss-as/server/ production /deploy/agComposer/">
          Options Indexes MultiViews
          AllowOverride None
          Order allow,deny
          Allow from all


          The mod_jk22.conf contains the following contents:
          LoadModule jk_module modules/mod_jk22.so
          JkWorkersFile conf/workers.properties
          JkMount /* node1
          JkLogFile logs/mod_jk.log
          # Set the jk log level [debug/error/info]
          JkLogLevel info
          # Select the log format
          JkLogStampFormat "[%a %b %d %H:%M:%S %Y]"

          The workers.properties contains the following contents:
          worker.list = node1
          worker.node1.host = 127.0.0.1
          worker.node1.port = 8009
          worker.node1.type=ajp13

          In server.xml we have given the following element:


          When we click on some link in application for editing, the application places the .doc file in “D:/jboss430/jboss-as/server/production/deploy/agComposer/templates� folder and apache picks up the file for editing. After we modify the content and click on save the document is getting saved on “C:\Program Files\Apache Software Foundation\Apache2.2� folder instead of updating in ‘D:/jboss430/jboss-as/server/production/deploy/agComposer/templates’.
          Please suggest us the alternate approach or provide us any configuration changes to achieve the same.



          • 2. Re: document save problem with apache 2.2 and JBoss 4.3
            raj reddy Newbie

            Hi,

            Currently our application is in production on WebLogic 9.2 with Apache 2.2 as web server and we need the same application to host on JBoss 4.3 EAP.

            Through our application we can edit .doc files, which is made possible with the use of Jacob.dll and MS ActivX at client. We have given virtual-directory-mapping in weblogic.xml where the location of .doc path is configured.

            We have installed JBoss in D:/jboss430 and apache 2.2.11 in C:\Program Files\Apache Software Foundation\Apache2.2.
            We have deployed application on JBoss 4.3 using Apache HTTP Server 2.2.11 successfully. We are facing one problem with respect to edit of document.

            We are able to open the document(.doc files) for editing, but after modifying the document, when we try to save the document using the save option in MS-Word, the copy of the same document is saved in Apache server folder instead of updating the document from the location from where it was opened. When we try to save the modified document into database, since application specific folder is not updated with user modified content, modified document is not getting saved into database.
            The httpd.conf file has the following content added/modified:

            Removed the comments for the following modules:

            1. LoadModule dav_module modules/mod_dav.so
            2. LoadModule dav_fs_module modules/mod_dav_fs.so

            Added the below lines at the bottom of httpd.conf

            Include conf/mod_jk22.conf

            DavLockDB /DavLock
            <Location /agComposer/templates>
            Dav On
            <Limit PROPFIND PUT POST DELETE PROPPATCH MKCOL COPY MOVE LOCK UNLOCK>
            Allow from localhost



            Alias /agComposer/ "D:/jboss430/jboss-as/server/production/deploy/agComposer/"

            <Directory "D:/jboss430/jboss-as/server/ production /deploy/agComposer/">
            Options Indexes MultiViews
            AllowOverride None
            Order allow,deny
            Allow from all


            The mod_jk22.conf contains the following contents:

            LoadModule jk_module modules/mod_jk22.so
            JkWorkersFile conf/workers.properties
            JkMount /* node1
            JkLogFile logs/mod_jk.log
            # Set the jk log level [debug/error/info]
            JkLogLevel info
            # Select the log format
            JkLogStampFormat "[%a %b %d %H:%M:%S %Y]"

            The workers.properties contains the following contents:
            worker.list = node1
            worker.node1.host = 127.0.0.1
            worker.node1.port = 8009
            worker.node1.type=ajp13

            In server.xml we have given the following element:


            When we click on some link in application for editing, the application places the .doc file in D:/jboss430/jboss-as/server/production/deploy/agComposer/templates folder and apache picks up the file for editing. After we modify the content and click on save the document is getting saved on C:\Program Files\Apache Software Foundation\Apache2.2 folder instead of updating in D:/jboss430/jboss-as/server/production/deploy/agComposer/templates.
            Please suggest us the alternate approach or provide us any configuration changes to achieve the same.