0 Replies Latest reply on Jun 23, 2009 3:50 AM by Adam Andrzejewski

    Jboss ear deployment - resourcebundle problem

    Adam Andrzejewski Newbie

      Hello, I have a strange problem with ear deployment.

      I have a multi-module project. One module is being archived to war, others to jars. The war module has some resource bundles, which are used in the application via standard seam messages component. And now - when i deploy the whole application on jboss 4.2 AS as an exploaded ear achive (just put the folder my-app.ear into jboss deploy folder) everything is working fine. But when I make an normal ear archive via ant task, or even from the command prompt and deploy it, my resource bundle messages are not being resolved and i recive ie. "message_exception_nodata" instead of normal error message (which as i said appears normally when using not archived ear folder).

      The main problem is that in the production enviroment i'm going to run this app at two clusters, and the ear goes into jboss farm folder, which as far as i know does work only with ear archives (exploaded directiories are not supported).

      I have looked for differences in the archive and the directory, and the only difference is that archive contains manifest file, so the ant build script doesnt mess it up.

      I also tried to move the resource bundles from the web module to some other modules - it didnt help, still the same problem occurs.

      I tried to modify the manifest file by adding the classpath definition consisting the module with the resources, and it also did not help.

      Any suggestions are warmly welcome