1 Reply Latest reply on Jul 16, 2009 11:21 AM by Peter Johnson

    Eclipse - jboss integration - jboss shuts down after startup

    Mahesh M Newbie

      Hi,

      I configured JBoss 4.0.5 GA in my system. It works perfectly fine from command prompt. However, when I configure it in Eclipse Ganymede/Eclipse JBoss IDE, the server starts, im seeing the "server started in .. " message. I can even access my application. But, the progress bar gives "starting" message and the jboss automatically stops in few minutes. I have tried increasing the Window > Preferences > Server > Server Time out delay to "Unlimited". Also, tried increasing the timeouts. None seems to work for me. I cannot work without debug mode. I am sure some one would have come across this problem earlier. Can some one throw light on this.

      I am using Eclipse Jboss IDE Version 2.0.0
      JBoss 4.0.5.GA
      JDK 1.6
      Windows Vista

      Thanks
      Mahesh

        • 1. Re: Eclipse - jboss integration - jboss shuts down after sta
          Peter Johnson Master

          Wow, really old stuff. And yes others have come across this same situation with the newer JBoss Tools and more recent versions of Eclipse.

          First some background. When Eclipse starts the app server, it monitors the Server MBean to determine when the server has fully started. To do that, it needs access to the JNDI port and the JMX ports.

          Eclipse can fail to recognize that the app server has started if:

          a) You change the JNDI or JMX ports
          b) You have the app server bind to an IP address other than localhost (or 0.0.0.0, which is the default in 4.0.5)
          c) You secure the JMX invoker, in which case Eclipse does not have access rights to JMX
          d) Your hosts file has an incorrect address for your system (if, for example, the DNS assigned a different address). One person actually had security set on the hosts file so that it was inaccessible.

          Those are the possible issues that come to mind.

          One thing to try is bring up the app server from the command line and then attempt to use the twiddle utility to access the Server MBean - if you you do that then Eclipse should be able to.

          I might even try using JDK 5 instead of 6, especially since 4.0.5 is not qualified with JDK 6.