1 Reply Latest reply on Aug 4, 2009 12:15 AM by jaikiran pai

    Compatibility with JBoss AS 5.1.0 GA and 4.0.2

    Nelson Foppa Jr Newbie

      Hello,

      I would like to know if the JBoss 5.1.0GA is compatible with the EJB 2.1 specification.
      I Want to migrate my application from version 4.0.2.
      I tried to deploy my application on jboss 5 and got this errors:

      Caused by: org.jboss.xb.binding.JBossXBException: Failed to parse source: cvc-complex-type.2.4.a: Invalid content was found starting with element 'jndi-name'. One of '{"http://java.sun.com/xml/ns/j2ee":ejb-ref-type}' is expected. @ vfszip:/usr/local/java/jboss-5.1.0.GA/server/postgres/deploy/erk-session-1.1-portal.jar/META-INF/ejb-jar.xml[18,16]
      at org.jboss.xb.binding.parser.sax.SaxJBossXBParser.parse(SaxJBossXBParser.java:203)

      ---
      Caused by: org.xml.sax.SAXException: cvc-complex-type.2.4.d: Invalid content was found starting with element 'read-only'. No child element is expected at this point. @ vfszip:/usr/local/java/jboss-5.1.0.GA/server/postgres/deploy/erk-cmp.jar/META-INF/ejb-jar.xml[9316,20]
      at org.jboss.xb.binding.parser.sax.SaxJBossXBParser$MetaDataErrorHandler.error(SaxJBossXBParser.java:426)

      Any help will be appreciated.