2 Replies Latest reply on Sep 16, 2009 6:34 AM by Roded Hess

    SMTPAppender

    Roded Hess Newbie

      I configured an SMTPAppender I enabled SMTPDebug and from the logs I always see that an attempt to create connection via localhost, 25 isSSL false occurs. No need to mention that I am using a SMTPHost attribute which is not localhost...
      I dont find where this behavior can be changed.
      Here is my appender:


















      Thanks,
      Rod

        • 1. Re: SMTPAppender
          Wolfgang Knauf Master

          Hi Rod,

          having to search your appender in the page source code is not fair ;-). Please repost it and wrap it in "[ code ]" tags. The preview your post before submitting.

          Best regards

          Wolfgang

          • 2. Re: SMTPAppender
            Roded Hess Newbie

            Woops :-)...
            I configured an SMTPAppender I enabled SMTPDebug and from the logs I always see that an attempt to create connection via localhost, 25 isSSL false occurs. No need to mention that I am using a SMTPHost attribute which is not localhost...
            I dont find where this behavior can be changed.
            Here is my appender:

             <appender name="EMAIL" class="org.apache.log4j.net.SMTPAppender">
             <param name="SMTPHost" value="smtp.gmail.com" />
             <param name="From" value="fromUser@gmail.com" />
             <param name="To" value="toUser@gmail.com" />
             <param name="SMTPDebug" value="true" />
             <param name="SMTPUsername" value="username" />
             <param name="SMTPPassword" value="password" />
             <param name="Subject" value="webapp error" />
             <layout class="org.apache.log4j.PatternLayout">
             <param name="ConversionPattern" value="[%d]%n%n%-5p%n%n%c%n%n%m%n%n" />
             </layout>
             <filter class="org.apache.log4j.varia.LevelRangeFilter">
             <param name="LevelMin" value="ERROR"/>
             <param name="LevelMax" value="FATAL"/>
             </filter>
             </appender>
            


            Thanks,
            Rod