3 Replies Latest reply on Dec 11, 2001 12:58 PM by Sacha Labourey

    Alpha/Beta Testing

    Alan Lewis Newbie

      Contrary to what Marc says ("you are not going to get immediate feedback, we are in alpha and this is a production feature") there is at least one alpha/beta tester out here...

      Using various JBoss 3.0 alpha-level builds in the previous weeks, I've tried running 2 JBoss instances on 2 different machines, and it does not appear as the JBoss instances "know" about each other and form a cluster as they should. I've tried running the JavaGroups examples, and those seem to work ok, so I'm guessing that there is some JBoss configuration I don't have right. Are there any other Clustering testers who have some configuration tips?

        • 1. Re: Alpha/Beta Testing
          Sacha Labourey Master

          Hello Alan,

          I am happy to see that you are trying the clustering features.

          Have you dropped the cluster-service.xml file in the deploy directory of your distribution?

          If not, here is what must be in this file:

          == cut == cut == cut == cut == cut == cut ==

          <?xml version="1.0" encoding="UTF-8"?>


          <!-- ===================================================================== -->
          <!-- -->
          <!-- Sample Clustering Service Configuration -->
          <!-- -->
          <!-- ===================================================================== -->





          JBOSS-SYSTEM:service=Naming

          <!-- ==================================================================== -->
          <!-- Cluster Partition: defines cluster -->
          <!-- ==================================================================== -->


          <mbean-ref-list name="SynchronizedMBeans">
          <mbean-ref-list-element>JBOSS-SYSTEM:service=HASessionState</mbean-ref-list-element>
          <mbean-ref-list-element>JBOSS-SYSTEM:service=HAJNDI</mbean-ref-list-element>
          </mbean-ref-list>


          <!-- ==================================================================== -->
          <!-- HA Session State Service for SFSB -->
          <!-- ==================================================================== -->




          <!-- ==================================================================== -->
          <!-- HA JNDI -->
          <!-- ==================================================================== -->






          == cut == cut == cut == cut == cut == cut ==

          Without this file, clustering is not enabled.

          The problem is that in the current alpha distribution, the file is missing (it is only available in the full CVS checkout).

          Come back to the forums if you still have problems.

          Cheers,



          Sacha

          • 2. Re: Alpha/Beta Testing
            Alan Lewis Newbie

            I know about the cluster-service.xml file not being in the kit... in fact I was the one who logged the bug about this problem :)

            OK, I tried it again this morning on two different machines, and PRESTO, it worked!

            Now I have to try and figure out why it wasn't working on the machines I was using yesterday. All of the machines I am using are Win2K variants with JDK1.3.1.... the only difference I can think of right now is that the machines that worked have static IP addresses (I think) while the ones that dont work use dynamic IP addresses. Would that make a difference?

            • 3. Re: Alpha/Beta Testing
              Sacha Labourey Master

              it shouldn't but if the IP addresses have changed while one of the server had started, it may be the reason why.